MarOS1.4.1 - "Official" Version 1.4.1
Moderators: Altitude, adafruit_support_bill, adafruit, phono, mome rath

Re: MarOS1.4.1 - "Official" Version 1.4.1 - IMPORTANT bugfix

by xlarge on Mon Jul 29, 2013 8:30 am

** No plans also to move to bigger CPU.

Really sure about that?
xlarge
 
Posts: 150
Joined: Wed Jul 11, 2007 2:02 pm

Re: MarOS1.4.1 - "Official" Version 1.4.1 - IMPORTANT bugfix

by dRead_SolJah on Thu Sep 05, 2013 3:22 pm

So, i really like MarOS and most of it the new randomizer-feature, keeps things interesting when out of creativity :mrgreen:

BUT maybe i´m dumb but i don´t get the x0x to the default classic midi-sync mode, to start the patterns on midi-clock signal!!!

I´m using a Electribe SX as master (as before with Sokkos), and i cant figure out what it means to "turn that mode off by pressing F#1 (Start-Mode-Key).Pressing it again, brings it back to classic mode."

Where should i press it? When should i press it?! Should i send a midi-note from Electribe, or press it on the xoxbox? do i need to enter a specific mode?! I cant figure it out :oops:

So please please help me, as this is a MUST HAVE for my livesets, cant spare a Sequencer-Line just for triggering the x0x....

THANKS ALOT !!!
Last edited by dRead_SolJah on Thu Sep 05, 2013 7:24 pm, edited 1 time in total.
dRead_SolJah
 
Posts: 2
Joined: Thu Sep 05, 2013 3:17 pm

Re: MarOS1.4.1 - "Official" Version 1.4.1 - IMPORTANT bugfix

by antto on Thu Sep 05, 2013 3:43 pm

i'd guess F#1 means a midi note, since the x0x keyboard is one octave only and thus no need to indicate octave (except on the C key)
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1380
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: MarOS1.4.1 - "Official" Version 1.4.1 - IMPORTANT bugfix

by dRead_SolJah on Thu Sep 05, 2013 7:25 pm

I tried this a 100 times, it doesn´t work for me....tried it in edit mode, sync mode, midi play and even when i press the tempo-knob.... :cry:
dRead_SolJah
 
Posts: 2
Joined: Thu Sep 05, 2013 3:17 pm

Re: MarOS1.4.1 - "Official" Version 1.4.1 - IMPORTANT bugfix

by antto on Fri Sep 06, 2013 3:50 am

i haven't tried this FW ever, so i'm just guessing here
the said midi-note might be required on a specific channel, could be the usualy midi-in channel (which is used for the MIDIPLAY mode) or another channel, give this a check

beyond that, ask Mario or look thru the code
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1380
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: MarOS1.4.1 - "Official" Version 1.4.1 - IMPORTANT bugfix

by mario1089 on Sun Sep 15, 2013 5:55 pm

Just re-checked it: Works for me. Toggle classic mode / non-classic mode by sending a MIDI message F#1 NoteOn on the correct MIDI input channel into the XoxBox! If you still have problems:

** Test the channel by testing whether the xox reacts (playing, pattern changes ect) when you press notes.
** Go back to SokkOS or whatever for a while and check your system. If it`s all fine, go back to MarOS.
** Minimize your MIDI system. I have seen a couple of times that somehow keyboards send everything TWICE, so that would mean it toggles on/off and you have the same state as before. Try sending MIDI with a DAW, not with hardware.
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

by Jeeroj on Fri Nov 01, 2013 11:16 am

Hey Mario,

First of all, I've got to say I'm LOVING this OS. The performance options are so useful! :D

1 quick question though, is the reset to step 1 function now removed?

In sokkos by holding chain or run and pressing previous it set the pattern back to its first step. I found this immensely useful after looping or editing patterns and having them come back in time but out of sync. It's very possible I've missed where this function is!

Thanks for all our hard work!
x0xb0x,FR revolution, es-1, ea-1, tr-606
Jeeroj
 
Posts: 7
Joined: Thu Jan 29, 2009 8:28 am
Location: Canterbury, UK

Re: MarOS1.4.1 - "Official" Version 1.4.1

by mario1089 on Fri Nov 29, 2013 8:19 am

yep, it could be "reset to step one" is removed - maybe unintendently, as I did now know about this feature. In case I work on it again (to fix some minor bugs only) I`ll have a look. Not sure when, though.

Thanx for liking:)
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS1.4.1 - "Official" Version 1.4.1

by Dazbo on Wed Mar 05, 2014 5:21 pm

Put this in my box a few nights ago,
Its wonderful - very very good indeed,im keeping it on,
well done.
Dazbo
 
Posts: 14
Joined: Mon Mar 03, 2014 5:03 pm

Re: MarOS1.4.1 - "Official" Version 1.4.1

by geux on Mon Mar 31, 2014 10:22 am

Hi,

I just discovered this OS, and it's wonderful ! :shock:
Very very innovative for live purpose. 8)

Here is a few things which are frustrating me :

. With x0x as master clock, when i run a pattern Sync out mode, and switch to pattern edit mode, the x0x stop to play when the pos switch is in pattern Din sync or Pattern Midi Sync.
(really annoying in live situation ...)

. I can't made the live parameters adjustment working (like swing or gate length).
I can access to the submenu by pressing the tempo button, I can modify these parameters by turning the tempo button, but this don't affect the sound AND I've not find a way to quit this submenu and saving the setting.

I'll try a previous version of MarOS or try again with this OS by reuploading again to my x0x, because I'm very frustated to didn't success to make it working in live situation.


Thank you anyway for your amazing work.

Guillaume
geux
 
Posts: 7
Joined: Mon Mar 03, 2014 6:49 pm

Re: MarOS1.4.1 - "Official" Version 1.4.1

by geux on Sun Apr 20, 2014 10:45 am

Hi again,

Sorry for the last post.
I tried it again today, by uploading again the FW (by c0nb0x), and it worked !!

No more sync problem, or gate time adjusting.

So thank you a lot for marOS, it's really awesome !!

My last question is about the faceplate.
Is it planned to make one, dedied to marOS ?

Than you anyway for your job :)
geux
 
Posts: 7
Joined: Mon Mar 03, 2014 6:49 pm

Re: MarOS1.4.1 - "Official" Version 1.4.1

by Paradigm X on Wed May 28, 2014 4:54 am

Hi Mario

I have also just put this OS on my two x0xen, and its fantastic! The swing and gate length adjustment is fantastic, the randomisation features are brilliant, and everything just sits together really nicely now (midi start bug fixed!)

Many thanks, appreciate the time you put into this!

cheers
User avatar
Paradigm X
 
Posts: 207
Joined: Sun Feb 07, 2010 3:49 pm

Re: MarOS1.4.1 - "Official" Version 1.4.1

by Paradigm X on Sat Sep 20, 2014 5:02 pm

Hey mario -

I absolutely love this firmware -

However, what midi note velocity does it send for accent on? It doesnt trigger the o.akley tm3030 which uses 100 or greater as velocity.

Sokkos 1.9.1 does send it correctly fwiw.

Many thanks, Ben
User avatar
Paradigm X
 
Posts: 207
Joined: Sun Feb 07, 2010 3:49 pm