MarOS1.4.1 - "Official" Version 1.4.1
Moderators: Altitude, adafruit_support_bill, adafruit, phono, mome rath

Need testing help for MarOS1.4

by mario1089 on Mon Nov 26, 2012 9:57 am

@pangrus (or anybody else): I have this new beta of upcoming MarOS1.4, posting it only for a test that I cannot do myself. Can you get it and test the DinSync output wether 1) it works generally and 2) the swing is applied also to the DinSync out, so that any slaved device swings the same way as the xoxbox does? Make sure is works in all tempo modes (normal, triplet, half-tempo, triplet-half-tempo) - the DinSync should not get affected by the tempo modes, slaved devices should continue as if nothing has happened, although the box changes the mode (24ppqn are 24 ppqn no matter what the box does within a quarter note).

You may also test the other new things, which are mostly fixes:
- Gate Lengths adjustment range fixed for triplet/half tempo/both
- Randomizer: F KEY 1st press: last action undo, 2nd press: revert pattern as stored, fast double press: revert to default "da-da-da..."
- Randomizer: NEXT KEY to randomize pattern end step/pattern length
- MIDI note pattern change fixed for pattern length not 16
- MIDI SYNC mode: tempo for swing apply is calculated from clock input, so swing amount is exactly right even if internal tempo is set to 20 or 250.
- Randomizer: SLIDE randomize (now on SLIDE KEY) fixed to not delete all accents (as in 1.3!)
- Some size-optimization have happened on adafruit/sokkOS code: 1) tempo setting with knob, or with software 2) using the note keys in run-write mode to set pitch of steps -- so maybe also have a quick look on these things?

Dont get confused, Randomizer buttons have partly moved around, no doc yet, you`ll sort it out:)
Last edited by mario1089 on Tue Nov 27, 2012 3:37 am, edited 1 time in total.
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by pangrus on Mon Nov 26, 2012 10:55 am

Great!
Yes, I'll test it asap and let you know.
User avatar
pangrus
 
Posts: 42
Joined: Fri Feb 25, 2011 10:20 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by am4d on Mon Nov 26, 2012 2:06 pm

Okay so I've had a little test.

The good:

Swing seems to transmit fine on DinSync in:
Normal mode
Half time
Triplet mode
Triplet Half mode

Gate length in all modes works fine
All functions of F key in edit mode work fine.
Next key randomises pattern length as expected.

The bad:

DinSync output when xox is slaved to midi clock seems to be all messed up and slow right now.
DinSync skips as triplet pattern starts (on first note)
Swing seems a bit jerky and off at times

Can someone else testing confirm or deny any of this?

P.S Mario i've also realised your firmware is missing the feature (from Osmk411) of stoping/starting DinSync with the run button when slaved to midi. I really liked this feature, any chance of adding it in?
Great work so far though.
am4d
 
Posts: 21
Joined: Tue Dec 27, 2011 5:17 pm

Re: MarOS - Fresh Firmware - Usability Update 1.3

by mario1089 on Mon Nov 26, 2012 4:52 pm

hmmm.. that sounds like some work to do.

so what we seem to have is that DinSync Output (including swing) generation works fine when box is in SYNC OUT or DINSYNC mode, but when in MIDISYNC mode, the output is "messed up and slow". Right?

"DinSync skips as triplet pattern starts"

I don`t understand, or not well enough to do something about it.

"Swing seems a bit jerky and off at times"

For what the box plays itself? or on sync ouput?

I`ll add that feature about the run button for 1.4. I`ll ask Omsk411 what he did, should be easy.

I feel a bit like it could be hard to get the DinSync right without some real gear. I know where to get a 808, but I would have to pay for it:( What would be the cheapest machine to buy (and sell again 2 weeks later) a ebay to test DinSync?
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by am4d on Mon Nov 26, 2012 5:22 pm

Yes, DinSync output works fine with everything, apart from when its slaved to midi it's messed up.

On the first note of a triplet pattern my 606 would skip. Like there's some missing or off-time clock ticks or something.

Swing seems messed up only on sync out sometimes.
Not so sure about that though, might just be my untrained ears.

Cheapest machine I know of with dinsync would be the tr-606 for about £250-ish.
I wonder if a cheap dinsync-midi converter box would work for you to test dinsync with any midi gear you have? probably not a very reliable test though.

Ill make some videos tonight to show you the bugs i'm trying to explain if it would help?

Thanks
am4d
 
Posts: 21
Joined: Tue Dec 27, 2011 5:17 pm

Re: MarOS - Fresh Firmware - Usability Update 1.3

by mario1089 on Mon Nov 26, 2012 5:27 pm

On the first note of a triplet pattern my 606 would skip. Like there's some missing or off-time clock ticks or something.


When changing to a triplet pattern, or when starting a triplet pattern?

I think for now you don`t have to do videos, let me first look and see. What I can`t sort out, I may ask again.. Thanx anyway.
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by mario1089 on Mon Nov 26, 2012 5:32 pm

Ah, and one more: If swing is a "little off at times", I guess you mean like for a moment, right? It doesn`t stay like that, but kinda recovers to be ok after, say, a second or so, without you doing anything?
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by mario1089 on Tue Nov 27, 2012 3:36 am

I changed a couple of things about what signal gets created in what mode, but I`m a little bit like guessing atm. At least I found one bad thing leading to out of sync situation when MIDI slaved.

So could you take a look on this new version? I`m not thinking it`s perfect or anything, it`s just we have to somehow approach..
Last edited by mario1089 on Tue Nov 27, 2012 5:39 am, edited 1 time in total.
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by am4d on Tue Nov 27, 2012 4:42 am

Beta1:
I also noticed when a triplet pattern is playing, devices on DinSync output and Midi output lose sync pretty quickly.
When playing a regular pattern they stay in sync perfectly

Beta2 just broke DinSync OUT :S (DinSync IN still works)
am4d
 
Posts: 21
Joined: Tue Dec 27, 2011 5:17 pm

Re: MarOS - Fresh Firmware - Usability Update 1.3

by pangrus on Tue Nov 27, 2012 4:45 am

With 1.4 beta 2 the Din Sync is generated but it seems the START signal is missing, as the external machines don't play....
User avatar
pangrus
 
Posts: 42
Joined: Fri Feb 25, 2011 10:20 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by mario1089 on Tue Nov 27, 2012 5:39 am

Ok, thanx guys. This is getting too difficult now, but I think I found someone with lots of old gear, let`s see how much that one is willing to support the hardware community:) Could take a week or so to get a device, but don`t worry, I usually don`t stop until something is finnished, be it software, be it music.
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by rarara on Tue Nov 27, 2012 6:00 am

mario1089 wrote:Ok, thanx guys. This is getting too difficult now, but I think I found someone with lots of old gear, let`s see how much that one is willing to support the hardware community:) Could take a week or so to get a device, but don`t worry, I usually don`t stop until something is finnished, be it software, be it music.

surely you have two x0xb0xes to let you test :lol:
rarara
 
Posts: 169
Joined: Wed Apr 05, 2006 9:47 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by pangrus on Tue Nov 27, 2012 6:10 am

Ok, I'll go back to 1.3 and wait patiently :D
Let me know if you need any other tests.
Hope to have soon a 1.5
cheers
User avatar
pangrus
 
Posts: 42
Joined: Fri Feb 25, 2011 10:20 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by mario1089 on Tue Nov 27, 2012 7:36 am

surely you have two x0xb0xes to let you test


well, no. There is one friend here with one but he f**ed up the building:) - But I think Ill get a 606 or 808 soon.
Anyway, I think I may give it another try tonight, as I think I understood something that is wrong. But don`t expect it to be right then, would only be a test. Hope I don`t waste too much of your time..
mario1089
 
Posts: 196
Joined: Wed Sep 19, 2012 8:11 am

Re: MarOS - Fresh Firmware - Usability Update 1.3

by roxxx303 on Tue Nov 27, 2012 9:22 am

Hi Mario,

please do not give up! You did some great work.
As a software developer I know how difficult things can get!
Please post new beta-versions (if you tested them to not harm the x0xb0x :wink: ).
I have some din-sync gear to test.

Perhaps you could record the DIN-Sync-x0x-Output to a PC and use a program to investigate it...? (Midi-OX?).
The Cable is the same as midi..?
User avatar
roxxx303
 
Posts: 83
Joined: Tue Nov 08, 2011 11:33 am