Cannot connect to microcontroller in Atmel Studio
Moderators: adafruit_support_bill, adafruit

Cannot connect to microcontroller in Atmel Studio

by awilder1015 on Mon Feb 11, 2013 3:21 pm

I'm taking a class on embedded microcontrollers, and I wanted to look at the program on the ATtiny2313 in Atmel Studio 6.0 to get a better idea of how it works, and perhaps make something similar to it for a class project.

When I connect the programming cable, and try to connect in the Device Programming menu, I get an error message that states "Read voltage 0.0V is outside selected device's operating range: 1.8 V to 5.5 V." I tried programming with the batteries in and with the batteries out, both gave me that same error message. I'm using Atmel's AVR programmer, if that makes any difference. I haven't tried putting any images in it, but the sample pre-programmed images appear to be working fine.

Does anyone know why this happens? If it cannot be fixed, Could someone email me the code on the microcontroller so I can see how it works?

Posts: 12
Joined: Mon Feb 11, 2013 3:10 pm

Re: Cannot connect to microcontroller in Atmel Studio

by adafruit_support_rick on Tue Feb 12, 2013 12:47 pm

Check that you have the right pinout on your programming cable. The SpokePOV has the standard 6-pin ICSP pinout. Sounds like maybe you have you cable in backwards?
What kind of programmer are you using? Are you sure you can even read back the contents of flash on the chip?

The source code for the SpokePOV is linked to on the SpokePOV project page. The hex file is also there - if you want to look at the raw machine code, it's probably easier to just look at that than to try to pull it off the chip.

Posts: 18462
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY