LED Strip Tutorial Issue

by wibbs on Fri Jan 04, 2013 11:19 pm

Hey Everyone,
Just got an Arduino and I've been toying with it. Alot of fun. The whole electrical engineering is new to me, but the coding is something i'm familiar with. I was following this adafruit tutorial (http://learn.adafruit.com/rgb-led-strips/usage) and i came across an issue. If i plug all the pins into their correct spots on the LED strip nothing happens. However, if I do something like: plug the green pin into the 12v input on the LED strip and plug the VIN pin to the green input, The LED strip will light up green. Like wise for blue and red. Basically the strip does not act as expected when it is plugged in correctly but it will glow Red, Green, or blue depending on where i plug the VIN pin. As i said i'm new to the electronics side and I have no idea what I could be doing wrong. I appreciate any help i can get!

PS. I am using a LED strip from think geek. It hooks up the same exact way. Has four inputs. 12v, R, G, B. It came with a little microcontroller that lets you select which color you want the LED strip to glow, fade, blink, etc etc. It's this item http://www.thinkgeek.com/product/ed07/?srp=2 . Could this be my problem. It seems no different to me.

Thanks!
wibbs
 
Posts: 1
Joined: Fri Jan 04, 2013 11:06 pm

Re: LED Strip Tutorial Issue

by adafruit_support_bill on Sat Jan 05, 2013 6:34 am

There are a lot of similar looking strips out there. Our strips are guaranteed to work with our tutorials.
User avatar
adafruit_support_bill
 
Posts: 25598
Joined: Sat Feb 07, 2009 9:11 am