Bricked Flora

by tektsu on Mon Feb 18, 2013 6:33 pm

My Flora is no longer recognized by the adafruit-arduino software. When plugged into USB, the green LED illuminate, and the yellow RX LED flickers occasionally. If i press the reset button, the red LED pulses 9 times. It never shows up under Tools ->Serial Port in the software.

I have tried more than one USB cable, and verified that other Arduinos work normally with the software. Of course, I have rebooted the computer. No change.

Is there anything else I can try to unbrick it?
tektsu
 
Posts: 18
Joined: Sun Nov 15, 2009 4:07 pm

Re: Bricked Flora

by adafruit on Mon Feb 18, 2013 9:21 pm

Anything show up in the device driver folder? what OS is the computer?
User avatar
adafruit
 
Posts: 11508
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc

Re: Bricked Flora

by tektsu on Tue Feb 19, 2013 8:09 am

The OS is OSX (Mountain Lion). I have loaded no device drivers.
tektsu
 
Posts: 18
Joined: Sun Nov 15, 2009 4:07 pm

Re: Bricked Flora

by adafruit_support_rick on Tue Feb 19, 2013 11:07 am

Hmmm... Can you look in the MacOS System Report and see if it shows up in the list of USB devices?
In the Apple Menu, click 'About this Mac.."
In the dialog, click the 'More Info..' button.
In the next dialog, click the "System Report...' button.
In the System Report window, expand the "Hardware" item in the left pane, and select 'USB' at the bottom of the list.

See if you can find the Flora in the list of USB devices.
User avatar
adafruit_support_rick
 
Posts: 8575
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY

Re: Bricked Flora

by tektsu on Wed Feb 20, 2013 6:36 pm

Well, I can't explain why this worked, but I got the Flora working again.

What I did was to open preferences.txt and type in the serial port name I wanted for the serial.port parameter. As soon as I did that and restarted the software, it recognized the Flora. Everything looks normal now.

Thanks for your help!
tektsu
 
Posts: 18
Joined: Sun Nov 15, 2009 4:07 pm

Re: Bricked Flora

by adafruit_support_rick on Wed Feb 20, 2013 7:12 pm

Okay, great! And we'll just add that one to the "Twilight Zone" folder... :shock:
User avatar
adafruit_support_rick
 
Posts: 8575
Joined: Tue Mar 15, 2011 10:42 am
Location: Buffalo, NY