Possibly faulty ST7565 Negetive LCD

by Sh33p on Sun Mar 17, 2013 5:39 pm

I believe the RED LEDs on my LCD are faulty. I have included pictures showing a "hello world" for RGB. The green and the blue are relatively bright enough but you cant even see the red except at extreme viewing angles. Ive placed a reflective surface next to the light so that you can see the red it on. When all three are on, I simply get a green blue hue. The red is completely indistinguishable I am powering the screen on 3.3v from a maple mini. I have also powered the screen on a separate power supply to check if the maple's current output was lacking but had the same results. Please let me know if this is the intended brightness for this screen or if i will be able to get an exchange.

I am not pwming the screen pins fyi. They are being pulled to ground from the maple. I have also plugged the pins directly to ground with the same results.

Thank you, I look forward to your reply.

Image
Image
Image
Sh33p
 
Posts: 7
Joined: Wed Feb 06, 2013 6:00 pm

Re: Possibly faulty ST7565 Negetive LCD

by adafruit_support_bill on Sun Mar 17, 2013 8:09 pm

How are you powering the backlight? Any current limiting resistors?
User avatar
adafruit_support_bill
 
Posts: 25556
Joined: Sat Feb 07, 2009 9:11 am

Re: Possibly faulty ST7565 Negetive LCD

by Sh33p on Sun Mar 17, 2013 9:29 pm

No currently limiting resistors. Just 3.3v directly to the backlight power wire.
Sh33p
 
Posts: 7
Joined: Wed Feb 06, 2013 6:00 pm

Re: Possibly faulty ST7565 Negetive LCD

by adafruit_support_bill on Mon Mar 18, 2013 5:05 am

Red is usually the strongest of the three. Seems to be a problem on yours. Contact support@adafruit.com with a link to this thread for a replacement.
User avatar
adafruit_support_bill
 
Posts: 25556
Joined: Sat Feb 07, 2009 9:11 am