Bricked FLORA with Pulse Sensor Amped
Moderators: adafruit_support_bill, adafruit

Bricked FLORA with Pulse Sensor Amped

by caitlinsdad on Thu Mar 21, 2013 10:41 am

1. Has anyone gotten the Pulse Sensor Amped to work with FLORA?

2. My two FLORAs were bricked by loading on the stock pulse monitor sketch and trying to run the Processing software for the heartbeat monitor.
FLORA was working fine(blink) with new IDE on WinXP machine. I then loaded the pulse monitor sketch code only modifying the input data pin 0 for FLORA's 10 and output blink LED to 7, fade LED to 9.
After upload, pulse monitor was lit green so power was good to vbatt and gnd. No red LED light on board when I held the pulse sensor in various positions. I know Pulse sensor is good as it was set up with hot glue/sticker cover and working on an Arduino UNO. I then thought code needed to be modified to try another data input pin or try with 3v low power. I pressed the reset button to see if things would kick off. Few flashes of the red LED, RX LED blinks and then nothing. When I tried to reload a sketch the IDE started complaining there was "No Leonardo to be found". Several attempts have the COM port disappearing and just hanging for a long time to upload until the IDE times out. Trying to press reset after uploading would only make the PC sound off with several "doinks" and give the same pattern of lights.

After several retries of unplugging the FLORA from the USB to reconnect, a few reboots of the PC, the COM port is reestablished. Pressing the reset button on gives the green LED lit constant, 8 fades of the red LED, and a few intermittent flashes of the RX LED.

So, research of the pulse sensor forum did not yield any solutions. The Blinking Series of Death lights on the FLORA was mentioned twice before on the adafruit forums and they mysteriously cleared up. I put my two FLORAs aside for a few days, yup, if it fails on one, brick the other just to make sure. I went back to try to reload the basic blink sketch in an attempt to reset the FLORA. Turning on the verbose mode in the IDE didn't help much since it was only a more cryptic message of no Leonardo found or missing COM port.

On a random try, after watching the verbose mode, when it gets to the repeating COM messages, I was able to press the reset button once, not holding it down for a second, and it seemed to allow it to catch and upload the blink sketch. Yay! Unbricked FLORA. I can brick the FLORA consistently but have not found the exact time to hit the reset as the sketch is trying to upload to unbrick it.

The questions still remain, is the BSOD lights indicative of some diagnostic of the FLORA? Since the pulse sensor uses serial/interrupts to output, did that code lock up the FLORA? Reading into the differences of a Leonardo Aduino, the virtural serial implemented may be incompatible or is not addressed correctly by the code. The IDE failure did have a message resetting COM to 9600 baud. There was some discussion with the 8bit timer on the pulse sensor forum but I don't know what to make of that.

I guess my plans to use the pulse sensor amped wth the FLORA are on hold until the kinks are worked out. Thanks.

btw, I did have that "cr*p, all my stuff is trashed, all that $$$ down the drain" moment but realized, it's cool, this is the bleeding edge of technology.
Posts: 18
Joined: Fri Feb 24, 2012 4:23 pm

Re: Bricked FLORA with Pulse Sensor Amped

by adafruit_support_bill on Thu Mar 21, 2013 11:10 am

Your Floras are probably not completely bricked. Try pressing the reset button just as the upload is about to start. It will probably take a few tries to hit the timing right, but they usually come around.
User avatar
Posts: 33833
Joined: Sat Feb 07, 2009 10:11 am

Re: Bricked FLORA with Pulse Sensor Amped

by caitlinsdad on Thu Mar 21, 2013 2:03 pm

Thanks, the FLORAs have recovered. It is hit or miss with the reset button because each time it is pressed, it will cycle the fade/rx blink sequence again.
Posts: 18
Joined: Fri Feb 24, 2012 4:23 pm

Re: Bricked FLORA with Pulse Sensor Amped

by AEcollin on Fri Mar 22, 2013 12:00 am

I am also experiencing this issue with my Pulse Sensor Amped with the FLORA. I am able to recover using the reset button, but every time I load the Pulse sample code it crashes. Any idea why this is happening?
Posts: 1
Joined: Sat Feb 09, 2013 7:42 pm

Re: Bricked FLORA with Pulse Sensor Amped

by caitlinsdad on Sat Mar 30, 2013 6:57 pm

Yay, user alw on posted a fix for the problem of using a pulse sensor amped with the flora.

Modify the arduino sample sketch code with the following to use a different timer(), comment out or delete the original corresponding timer2 references

Code: Select all | TOGGLE FULL SIZE
TCCR0A = 0x02;
TCCR0B = 0x04; // these put the timer into CTC mode and set the prescaler to 256

OCR0A = 0x7C; // timer0 counts to 124, then gets reset to 0

TIMSK0 = 0x02; // enable interrupt on OCR0A match

//The only other thing you will need is the correct isr vector


Read more: ... z2P4B5HeAH

No more locking up of the Flora when that sketch is uploaded.
Posts: 18
Joined: Fri Feb 24, 2012 4:23 pm