Please be aware of all shipping deadlines before placing your order - we cannot guarantee orders will arrive before Christmas!

DC Boarduino error stk500_getsync(): not in sync: resp=0x5c
Moderators: adafruit_support_bill, adafruit

DC Boarduino error stk500_getsync(): not in sync: resp=0x5c

by greenmoon on Sat Mar 23, 2013 12:23 am

I just built the DC Boarduino w/ ATmega328. The green LED lights up when I power on. I am using an FTDI Friend to connect to my laptop. When I try to upload a sketch, things seem to be going well until the very end, when I get this error:
avrdude: stk500_getsync(): not in sync: resp=0x5c

This tutorial says I should choose "Diecimila/Duemilanove with 328P" as the board, but that is not an option:
http://www.ladyada.net/make/boarduino/use.html
So, I have tried "Arduino Duemilanove w/ ATmega328". Not sure if that is the right board or not. Please advise.

Also, I have seen others talk about the jumper. I am not sure which is the right way. I tried it both ways. I cannot find any guidance on which position is which. Please advise.

Thanks.
greenmoon
 
Posts: 6
Joined: Tue Mar 19, 2013 3:58 pm

Re: DC Boarduino error stk500_getsync(): not in sync: resp=0x5c

by adafruit_support_bill on Sat Mar 23, 2013 7:30 am

"Arduino Duemilanove w/ ATmega328" is the correct board type. For use with the FTDI Friend, the jumper should be in the "usb" position (closest to C6). Double check that you have the correct COM port selected.

Also, when you press the reset button, do you get 3 flashes on the red LED?
User avatar
adafruit_support_bill
 
Posts: 32638
Joined: Sat Feb 07, 2009 10:11 am

Re: DC Boarduino error stk500_getsync(): not in sync: resp=0x5c

by greenmoon on Sat Mar 23, 2013 10:10 am

Thank you for your quick response!

Yes, I get 3 flashes of the LED. But let me see if I understand the use of the jumper. When I have it set to USB, should I also be getting power to the board from the USB? When I set the jumper to USB and plug in the FDTI, I do not get the green light. I only get the green light if the jumper is set to DC and I have it hooked up to a battery (that's when pressing reset flashes the red LED).

If I am supposed to get power from the USB, then that is not working and I guess I need to troubleshoot that. But please confirm that my understanding of the jumper is correct.
greenmoon
 
Posts: 6
Joined: Tue Mar 19, 2013 3:58 pm

Re: DC Boarduino error stk500_getsync(): not in sync: resp=0x5c

by adafruit_support_bill on Sat Mar 23, 2013 2:11 pm

That is correct. With the jumper set to "usb", you should be getting power from the FTDI cable.

If you post photos of the front and back of the board, we can look it over for any assembly issues that might be affecting USB power.
User avatar
adafruit_support_bill
 
Posts: 32638
Joined: Sat Feb 07, 2009 10:11 am

Re: DC Boarduino error stk500_getsync(): not in sync: resp=0x5c

by greenmoon on Sat Mar 23, 2013 6:49 pm

Here are photos of the front and back. I think I am going to try to resolder the 6-pin strip for the FTDI. Maybe work backwards from that end. Let me know if you see anything or have any other suggestions.
Attachments
20130323_1523.JPG
Bottom
20130323_1523.JPG (107.16 KiB) Viewed 519 times
20130323_1524.JPG
Top
20130323_1524.JPG (123.29 KiB) Viewed 519 times
greenmoon
 
Posts: 6
Joined: Tue Mar 19, 2013 3:58 pm

Re: DC Boarduino error stk500_getsync(): not in sync: resp=0x5c

by adafruit_support_bill on Sat Mar 23, 2013 7:51 pm

Don't see any problems on the component side. The solder-side photo is a bit fuzzy, bot the top two solder joints on the FTDI connection do look a bit suspicious. Retouch those joints and make sure that the solder has flowed well onto both the pin and the surrounding solder pad. http://learn.adafruit.com/adafruit-guid ... n-problems
User avatar
adafruit_support_bill
 
Posts: 32638
Joined: Sat Feb 07, 2009 10:11 am

Re: DC Boarduino error stk500_getsync(): not in sync: resp=0x5c

by greenmoon on Sun Mar 24, 2013 10:08 am

That was it! Great diagnosis from a blurry photo. You guys are amazing. Thank you so much!
greenmoon
 
Posts: 6
Joined: Tue Mar 19, 2013 3:58 pm