Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

Error taking Snapshot with Waterproof TTL Serial JPEG Camera
Moderators: adafruit_support_bill, adafruit

Error taking Snapshot with Waterproof TTL Serial JPEG Camera

by idanb on Sun Mar 31, 2013 5:31 pm

Hi All,

Problem:
Running the Snapshot.pde I'm unable to produce a photo through the Waterproof TTL Serial JPEG Camera. I receive the following error:

"VC0706 Camera snapshot test
Card failed, or not present"

Hardware:
Arduino Wifi Shield
Arduino Mega ATK
Waterproof TTL Camera

Changes made:
In Sd2Card.h:
#define MEGA_SOFT_SPI 1

Snapshot.pde:
#define chipSelect 4

SoftwareSerial cameraconnection = SoftwareSerial(69, 3);
Adafruit_VC0706 cam = Adafruit_VC0706(&cameraconnection);

Any help will be mich appreciated :D

Thank you,

Idan
Attachments
Photo on 2013-03-31 at 22.28.jpg
Photo on 2013-03-31 at 22.28.jpg (167.83 KiB) Viewed 558 times
Photo on 2013-03-31 at 22.21.jpg
Photo on 2013-03-31 at 22.21.jpg (142.46 KiB) Viewed 558 times
idanb
 
Posts: 7
Joined: Mon Mar 11, 2013 7:53 am

Re: Error taking Snapshot with Waterproof TTL Serial JPEG Camera

by adafruit_support_bill on Mon Apr 01, 2013 5:42 am

To rule out a conflict with the WiFi shield, can you try it with just the Uno?

adafruit_support_bill
 
Posts: 37526
Joined: Sat Feb 07, 2009 10:11 am

Re: Error taking Snapshot with Waterproof TTL Serial JPEG Camera

by idanb on Mon Apr 01, 2013 7:57 am

Hi,

There is a conflict with the wifi shield, since I managed to take a photo.

I did the following changes:

Hardware:
Adafruit Micro-SD breakout board
Arduino Mega ATK
Waterproof TTL Camera

Changes made:
In Sd2Card.h:
#define MEGA_SOFT_SPI 0

Snapshot.pde:
#define chipSelect 10

SoftwareSerial cameraconnection = SoftwareSerial(69, 3);
Adafruit_VC0706 cam = Adafruit_VC0706(&cameraconnection);

Since I need wifi support for my project, how can you assist in debugging the problem?

Thanks,

Idan
idanb
 
Posts: 7
Joined: Mon Mar 11, 2013 7:53 am

Re: Error taking Snapshot with Waterproof TTL Serial JPEG Camera

by adafruit_support_bill on Mon Apr 01, 2013 8:12 am

We don't sell the WiFi shield and I don'[t have one here to test with. But according to the board pinouts, there should be no pin conflicts with the camera as you have it wired: http://arduino.cc/en/Main/ArduinoWiFiShield

However, in your second test, you wired the SPI for the SD differently. Try it using Soft-SPI on pins 10-13 as it is on the Wi-Fi card. There may be a library conflict with soft-spi.

adafruit_support_bill
 
Posts: 37526
Joined: Sat Feb 07, 2009 10:11 am

Re: Error taking Snapshot with Waterproof TTL Serial JPEG Camera

by idanb on Tue Apr 02, 2013 4:59 am

Hi,

I found out that I can connect the TX and RX directly to the MEGA board to RX1 and TX1 on a hardware level and not do any Software Serial changes.

Thank you for your support!!! :D

Idan
idanb
 
Posts: 7
Joined: Mon Mar 11, 2013 7:53 am