Verification error, content mismatch (Arduino Uno)
Moderators: adafruit_support_bill, adafruit

Re: Verification error, content mismatch (Arduino Uno)

by phineasjw on Tue May 07, 2013 3:49 pm

I waited a day before posting and tested it on more than one board - called the fix code and posted. Then started programming more boards - failure. Resetting the target board just before programming can get it to work sometimes- not very reliable though. One will program, one won't. Frustration continues.
phineasjw
 
Posts: 2
Joined: Tue May 07, 2013 1:44 pm

Re: Verification error, content mismatch (Arduino Uno)

by westfw on Tue May 07, 2013 7:25 pm

Were you (phineasjw) talking about optiloader.h in the Adafruit Standalone-Arduino-AVR-ISP-programmer enhancement of "optiLoader"? I can't find an "optiboot.h" associated with ANYTHING, and the original optiLoader and optiboot source doesn't contain any mention of CLOCKSPEED_FUSES...

If I had 1000 boards for some real project, I'd be buying a production-quality AVR ISP programmer.
Maybe http://www.kanda.com/products/kanda/HH0110.html ? (no personal experience with that, but Kanda has been around for a long time and has a decent reputation.)

If you're willing to sacrifice a board that consistently fails to program, I'd be willing to take a look at it and see if I can figure out what is going wrong. (get a shipping address via pm)
User avatar
westfw
 
Posts: 1373
Joined: Fri Apr 27, 2007 1:01 pm
Location: SF Bay area

Re: Verification error, content mismatch (Arduino Uno)

by janhiev on Wed Nov 13, 2013 7:24 am

a little late and for the atmega328p...
take the bootloader for your type and it should work.

try this...http://rajeshkovvuri.wordpress.com/2011/09/21/arduino022-and-issues-with-sketch-uploading/

the uno works fine and the error is gone.
janhiev
 
Posts: 1
Joined: Wed Nov 13, 2013 7:17 am