Get 12% off, TODAY ONLY 12/12 – use the code TWELVE on check out! Some restrictions apply!

Arduino UNO SMD Problem uploading to Board
Moderators: adafruit_support_bill, adafruit

Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Thu Jan 27, 2011 10:37 pm

avrdude: stk500_getsync(): not in sync: resp=0xf9
avrdude: stk500_disable(): protocol error, expect=0x14, resp=0x51


I have the code compiled correctly with no errors. its just that It will not sync properly with the actual Arduino uno smd. what can I do to make this happen. :cry:
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm

Re: Arduino UNO SMD Problem uploading to Board

by adafruit_support_bill on Fri Jan 28, 2011 7:05 am

Do you have the "Arduino Uno" selected as the board type in the Tools menu of the IDE?
User avatar
adafruit_support_bill
 
Posts: 32597
Joined: Sat Feb 07, 2009 10:11 am

Re: Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Fri Jan 28, 2011 4:35 pm

Yes I have tried that already......
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm

Re: Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Fri Jan 28, 2011 5:39 pm

It does not work. Anything else???? :? :x
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm

Re: Arduino UNO SMD Problem uploading to Board

by franklin97355 on Fri Jan 28, 2011 11:12 pm

Check your cable, check power (is the level correct?), tell us what it does and what it does not, did it ever work?, do you have any drivers loaded?, how are you powering it. does your computer see the board? (other than when you are uploading code), what operating system are you using? Try these and let us know.
User avatar
franklin97355
 
Posts: 6172
Joined: Mon Apr 21, 2008 2:33 pm

Re: Arduino UNO SMD Problem uploading to Board

by bertobot on Fri Jan 28, 2011 11:18 pm

I think I'm having the same problem. An orange LED keeps blinking, but is otherwise unable to speak to the computer. I shot a video to show what I see.

http://www.youtube.com/watch?v=VFty7V5E0xQ

I'll borrow my friend's older arduino and update the bootloader, as I'm entirely sure I'm experiencing what's described on arduino's site:

http://arduino.cc/blog/2011/01/20/issue ... d-edition/
bertobot
 
Posts: 2
Joined: Fri Jan 28, 2011 9:54 pm

Re: Arduino UNO SMD Problem uploading to Board

by adafruit on Sat Jan 29, 2011 10:39 am

bertobot wrote:I'll borrow my friend's older arduino and update the bootloader, as I'm entirely sure I'm experiencing what's described on arduino's site:

http://arduino.cc/blog/2011/01/20/issue ... d-edition/


the arduinos sold from adafruit do not have this issue, it is extremely unlikely that you are experiencing this
User avatar
adafruit
 
Posts: 11778
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Sat Jan 29, 2011 7:05 pm

Well, I purchased my arduino from adafruit.

Is there a way you can tell how to do the whole process from step to step?

From uploading the software ( if I even did it correctly) all the way to the Driver Installation.

Like I said earlier it shouldn't be the software because my code is compile ( everything is good with that end) :o

But I think it has something to do with the way i installed the Driver. :?:

help me out yall. :(
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm

Re: Arduino UNO SMD Problem uploading to Board

by adafruit on Sat Jan 29, 2011 8:50 pm

Deeloc20z wrote:Well, I purchased my arduino from adafruit.


if you look carefully, you will see we were not responding to you

Is there a way you can tell how to do the whole process from step to step?

From uploading the software ( if I even did it correctly) all the way to the Driver Installation.

Like I said earlier it shouldn't be the software because my code is compile ( everything is good with that end) :o

But I think it has something to do with the way i installed the Driver. :?:

help me out yall. :(


there is a tutorial here
http://arduino.cc/en/Guide/HomePage
User avatar
adafruit
 
Posts: 11778
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Sun Jan 30, 2011 1:00 pm

I believe the problem is with the Driver Installation, because on the tutorial it ask me to go into the Device Manager and right click on Arduino Uno (port comxx) which I did and go to the Device Update. But says to select on ArduinoUNO.inf ( which by the way I do not have as an option) and I only have the FTDI USB Drivers sub-directory, and the tutorial says not to select FTDI USB Drivers sub-directory. Since that was the only option I had I went ahead and tried it again But a CANNOT CONTINUE THE HARDWARE UPDATE WIZARD message popped up. It also says The wizard couldn't find a better match for my Hardware than the software I have installed. So what should I do since i DO not have a ArduinoUNO.inf option ( I believe that is what I really need ,the Arduino UNO.inf option). #1. could It a be the way I installed the software even though it works and compiles my code with no errors? #2. is it the the Driver Installation with the ArduinoUNO.inf problem? what should I do Ardwuino???? :oops: :?: :| :x :(
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm

Re: Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Sun Jan 30, 2011 1:03 pm

My last message is for both ADAFRUIT and ARDWINO...... :wink: :wink: 8)
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm

Re: Arduino UNO SMD Problem uploading to Board

by adafruit_support_bill on Sun Jan 30, 2011 1:53 pm

But says to select on ArduinoUNO.inf ( which by the way I do not have as an option)

If you do not have ArduinoUno.inf in your drivers directory (...\arduino-0022\drivers) then you should re-download the Arduino environment and start again. it IS in there.
and I only have the FTDI USB Drivers sub-directory, and the tutorial says not to select FTDI USB Drivers sub-directory.

It is in the top level of the 'drivers' folder. You do not need to select any sub-directory.
The wizard couldn't find a better match for my Hardware than the software I have installed

If you have already installed the wrong driver, un-install it and start over.
User avatar
adafruit_support_bill
 
Posts: 32597
Joined: Sat Feb 07, 2009 10:11 am

Re: Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Mon Jan 31, 2011 3:30 am

I know this may be A silly question.[i] But how do i succefully uninstall the software and the driver installation[/i]? The only thing I always do is delete from my desktop ( which I know it still is the computer hardware stored somewhere). I need it to be completly gone and erased from my whole desktop ( INSIDE AND OUT)...... Tips and advice please :oops: :oops: :? :?: :lol: `
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm

Re: Arduino UNO SMD Problem uploading to Board

by adafruit_support_bill on Mon Jan 31, 2011 7:10 am

Open up the Control Panel and go to the Device Manager. Right click on the device and select "uninstall". Depending on which version of Windows you are running, the device might need to be connected when you do that.
User avatar
adafruit_support_bill
 
Posts: 32597
Joined: Sat Feb 07, 2009 10:11 am

Re: Arduino UNO SMD Problem uploading to Board

by Deeloc20z on Mon Jan 31, 2011 11:38 am

WHAT ABOUT UNINSTALLING THE SOFTWARE?? :?: HOW DO I DO THAT ? :mrgreen:
Deeloc20z
 
Posts: 12
Joined: Thu Jan 27, 2011 8:37 pm