Programmer is not responding
Moderators: adafruit_support_bill, adafruit

Programmer is not responding

by j'ke on Sat Nov 10, 2012 7:44 pm

I have a problem :)

When uploading a sketch it says that the programmer is not responding.
When resetting the rx and tx led's do not blink.

I'm using an arduino uno on a macbook pro os 10.7.5 with the 1.0 software.

Serious bummer. Could it be that i shorted out the board and that the bootloader is gone/broken or some sort?

Thanks a lot!
j'ke
 
Posts: 30
Joined: Sun Dec 11, 2011 11:08 am

Re: Programmer is not responding

by adafruit_support_mike on Sun Nov 11, 2012 12:55 am

Are you sure you've selected the board and serial port correctly under the Arduino IDE's "Tools" menu? That's a common gotcha.
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 11337
Joined: Thu Feb 11, 2010 2:51 pm

Re: Programmer is not responding

by j'ke on Sun Nov 11, 2012 7:27 am

Yes the right board and port are selected. Been playing around for 7 months with it and it always worked fine.
But now i wanted to try my own thing but i missed something on my breadboard. First i got the message 'the usb
devive is drawing to much power...' and after that when i saw my circuit fault the arduino programmer stopped responding.
:(
j'ke
 
Posts: 30
Joined: Sun Dec 11, 2011 11:08 am

Re: Programmer is not responding

by adafruit_support_bill on Sun Nov 11, 2012 8:50 am

That doesn't sound good. But it may be salvageable.
Does your Mac still recognize that the Arduino has been plugged in?
Do you see any led activity when you press the reset button?
Do you see any led activity when you attempt to upload?
User avatar
adafruit_support_bill
 
Posts: 32625
Joined: Sat Feb 07, 2009 10:11 am

Re: Programmer is not responding

by j'ke on Sun Nov 11, 2012 9:36 am

adafruit_support wrote:That doesn't sound good. But it may be salvageable.
Does your Mac still recognize that the Arduino has been plugged in?
Do you see any led activity when you press the reset button?
Do you see any led activity when you attempt to upload?


He still recognize the arduino. Only the 'on' led and the led that is connected to pin 13 are working.
The rx and tx led don't blink at all after reset.

When uploading a sketch only the led on pin 13 flikkers and then i get the programmer is not responding message.
j'ke
 
Posts: 30
Joined: Sun Dec 11, 2011 11:08 am

Re: Programmer is not responding

by adafruit_support_bill on Sun Nov 11, 2012 10:21 am

It sounds like the 16U2 is still partially functional. It is identifying as an UNO when you plug it in. But if the Rx & Tx do not blink as you attempt to upload, it is not communicating with the Atmega 328. You might be able to revive it by re-flashing it as described in this thread: viewtopic.php?f=25&t=25146

Does the led13 flash a few times after reset? That indicates that the bootloader is working. If not, you may need to replace the Atmega 328: http://www.adafruit.com/products/123. (Note - the bootloader on this is Duemilanove compatible, so you would need to select "Duemilanove w/328" as your board type.)
User avatar
adafruit_support_bill
 
Posts: 32625
Joined: Sat Feb 07, 2009 10:11 am

Re: Programmer is not responding

by j'ke on Sun Nov 11, 2012 10:33 am

I will try the reflashing thing.

The led pin 13 led flashes after reset and uploading. So it's not the bootloader, that's good :)

Thx a lot for the help!
j'ke
 
Posts: 30
Joined: Sun Dec 11, 2011 11:08 am

Re: Programmer is not responding

by j'ke on Tue Nov 13, 2012 4:30 pm

Reflashing failed so il will just buy a new arduino :)
Many thx for the help!
j'ke
 
Posts: 30
Joined: Sun Dec 11, 2011 11:08 am