NeoPixel Digital 60 LED Not Working
Moderators: adafruit_support_bill, adafruit

NeoPixel Digital 60 LED Not Working

by rej4449 on Sat Feb 02, 2013 9:33 pm

I ordered a 1 meter NeoPixel Digital RGB LED Weatherproof 60 LED strip from Adafruit. I downloaded the library, dropped it in my libraries folder and loaded the strandtest program on one of my UNOs. I verified that I was calling the Adafruit_NeoPixel library correctly. I used a regulated 5V 2A bench supply. The hardware is wired correctly. The sketch compiled and uploaded correctly. The LED strip remained dark. I verified everything (correct) and tried running the sketch on a Mega 2560. The LED strip remained dark. I tried different pins, to no avail. Wiring three connections is absurdly simple, so there are NO wiring errors. I tried running the sketch in the Arduino ERW 1.0.3 and Visual Studio 11 environments. It made no difference. I scoped the output of the pin and found the voltage loaded down to 4.1VDC with pulses ringing about 200mv p/p. I would love to debug but can't do much with the assembler code.

Has anyone else tried the NeoPixel 60 LED strips and managed to get one to work? Did you have good pulses on the digital pin?

I appreciate any help I can get.

BTW, I am a BSEE with coding and hardware experience. I am fairly new to Arduinos, but I have developed and debugged several complex sketches. So I am not a n00b.

Thanks
rej4449
 
Posts: 3
Joined: Sun Dec 23, 2012 4:04 am

Re: NeoPixel Digital 60 LED Not Working

by rej4449 on Sat Feb 02, 2013 11:09 pm

In 40 years of engineering, I have never seen a problem like this. I replaced all the jumpers but one. That one was (almost) open. There must have been a single strand that was intermittently connecting. When I hooked up the scope, it would almost work. I guess an old dog can learn new tricks.

Thanks.

Bob
rej4449
 
Posts: 3
Joined: Sun Dec 23, 2012 4:04 am

Re: NeoPixel Digital 60 LED Not Working

by pburgess on Sun Feb 03, 2013 12:55 am

Whew! That's a relief. Glad you got it working.

Lovely, aren't they?
User avatar
pburgess
 
Posts: 2739
Joined: Sun Oct 26, 2008 2:29 am

Re: NeoPixel Digital 60 LED Not Working

by rej4449 on Sun Feb 03, 2013 11:59 pm

Indeed they are! I would have spent the entire day playing with them except for the Superbowl. Well, at least I have the Giants to look forward to.

Bob
rej4449
 
Posts: 3
Joined: Sun Dec 23, 2012 4:04 am