RFID/NFC Shield not starting
Moderators: adafruit_support_bill, adafruit

RFID/NFC Shield not starting

by anouncement on Tue Oct 09, 2012 12:17 am

I recently received the NFC/RFID shield (Adafruit PN532 NFC/RFID Controller Shield for Arduino + Extras) and it fails to initialize. I am using a Leonardo board.

I soldered the pins onto the NFC board. I verified that they were all good solder joints using a continuity tester.

I'm running this on a mac. The arduino board by itself works normally. It just doesn't work with the NFC shield. I installed macports + all the required libraries and extras. When I run the readMifare test, it fails to load anything. All I see is "Hello!" on the screen.

I modified the script/sketch and it looks like it's failing on the uint32_t versiondata = nfc.getFirmwareVersion(); and turned on debugging in the .ccp files. I see it sends a string of hex code to the nfc board, and then it never returns.

Any ideas?

Thanks!
--
Anouncement
anouncement
 
Posts: 3
Joined: Tue Oct 09, 2012 12:07 am

Re: RFID/NFC Shield not starting

by adafruit_support_bill on Tue Oct 09, 2012 6:04 am

Post clear photos of the shield showing all your solder joints.
User avatar
adafruit_support_bill
 
Posts: 31820
Joined: Sat Feb 07, 2009 10:11 am

Re: RFID/NFC Shield not starting

by anouncement on Mon Oct 15, 2012 12:22 am

Here are some shots of my solder joints. I can retake some more if necessary.

2012-10-14_21-10-26_851.jpg
2012-10-14_21-10-26_851.jpg (890.17 KiB) Viewed 1092 times


2012-10-14_21-10-18_526.jpg
2012-10-14_21-10-18_526.jpg (930.07 KiB) Viewed 1092 times


2012-10-14_21-10-09_636.jpg
2012-10-14_21-10-09_636.jpg (834.63 KiB) Viewed 1092 times
--
Anouncement
anouncement
 
Posts: 3
Joined: Tue Oct 09, 2012 12:07 am

Re: RFID/NFC Shield not starting

by adafruit_support_bill on Mon Oct 15, 2012 6:17 am

I am using a Leonardo board.

I'm not sure that this shield is compatible with the Leonardo. (Due to the difference in pin mapping, many shields are not)
(From the product description)
Compatible with any "classic" Arduino - NG, Diecimilla, Duemilanove, UNO - as well as Mega R3 or later.


Your soldering looks fine. Do you have a regular Arduino to test it with?
User avatar
adafruit_support_bill
 
Posts: 31820
Joined: Sat Feb 07, 2009 10:11 am

Re: RFID/NFC Shield not starting

by anouncement on Mon Oct 15, 2012 10:53 am

adafruit_support wrote:Your soldering looks fine. Do you have a regular Arduino to test it with?


Sadly, I do not. :-(

Do you have the pin-out diagram? I could probably bread-board something to get it working if I knew which pins went where.

Thanks
--
Anouncement
anouncement
 
Posts: 3
Joined: Tue Oct 09, 2012 12:07 am

Re: RFID/NFC Shield not starting

by adafruit_support_rick on Mon Oct 15, 2012 11:09 am

The shield *should* work with Leonardo in I2C mode, I think. Are there any LEDs lit on the shield?

If it's hanging up waiting for getFirmwareVersion to return, that means the arduino is not seeing the IRQ signal coming back from the shield. You are using digital 2 for IRQ?

Check the solders on the pins marked SDA, SCL, and digital 2. In your pictures, the solder on SCL looks a little iffy.

Here's the schematic:
PN532_Shield_v1.0.png
PN532_Shield_v1.0.png (69.78 KiB) Viewed 1072 times
Last edited by adafruit_support_rick on Mon Oct 15, 2012 11:16 am, edited 1 time in total.
Reason: added schematic

adafruit_support_rick
 
Posts: 13810
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: RFID/NFC Shield not starting

by adafruit_support_bill on Mon Oct 15, 2012 1:50 pm

The shield *should* work with Leonardo in I2C mode, I think.

The I2C should work, but I think it will interfere with the IRQ on pin 2 as used by the shield. I2C on the Leonardo is on pins 2 & 3.
User avatar
adafruit_support_bill
 
Posts: 31820
Joined: Sat Feb 07, 2009 10:11 am

Re: RFID/NFC Shield not starting

by adafruit_support_rick on Mon Oct 15, 2012 1:58 pm

adafruit_support wrote:The I2C should work, but I think it will interfere with the IRQ on pin 2 as used by the shield. I2C on the Leonardo is on pins 2 & 3.

Ah - that would do it. In that case, I guess you would have to cut the trace from pin 2 to IRQ, and then jumper IRQ to a different digital pin.

adafruit_support_rick
 
Posts: 13810
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: RFID/NFC Shield not starting

by adafruit_support_bill on Mon Oct 15, 2012 1:59 pm

The Leo has external interrupts on pins 0 & 1 also.
User avatar
adafruit_support_bill
 
Posts: 31820
Joined: Sat Feb 07, 2009 10:11 am

Re: RFID/NFC Shield not starting

by adafruit_support_rick on Mon Oct 15, 2012 2:02 pm

Actually, the IRQ line is not used as an interrupt in the library, so it can be assigned to any free pin.

adafruit_support_rick
 
Posts: 13810
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: RFID/NFC Shield not starting

by Serge MAROTTE on Sun Feb 17, 2013 3:14 pm

Hi, I'm trying to use the RFID/NFC PN532 with a Arduino DUE
The serial monitor said :
Hello!
Didn't find PN53x board

There is a lot of informations about this problem on the internet but nothing
about the couple PN532 shield <> Arduino DUE

My first and basic question is :
Is the PN532 compatible with the Arduino DUE ???

Merci !!!

Serge Marotte
Serge MAROTTE
 
Posts: 1
Joined: Sun Feb 17, 2013 3:05 pm

Re: RFID/NFC Shield not starting

by adafruit_support_rick on Sun Feb 17, 2013 8:04 pm

Sorry! We have not tested the RFID/NFC Shield with the Due yet. I don't know what sort of compatibility issues there are, nor whether they can be easily resolved.

adafruit_support_rick
 
Posts: 13810
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY