NFC Shield - Didn't find PN53x board
Moderators: adafruit_support_bill, adafruit

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Fri Nov 09, 2012 7:07 am

Contact support@adafruit.com with a link to this thread and ask for a replacement shield. Your assembly looks fine & the example sketch should be able to at least communicate with the board.
User avatar
adafruit_support_bill
 
Posts: 31029
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by RayBATL on Tue Nov 27, 2012 11:50 pm

I have an Uno 1.0 so it doesn't have a pin for IOref. Do I need to do something with that pin on my shield? I have confirmed all my solder connections with a meter. The power and busy lights are on.

I downloaded and installed the Adafriut_PN532_master library. Uploaded mifareclassic_formatndef successfully. When I launch the serial monitor I get "Looking for PN532..." , "Didn't find PN53x board". Per this thread I uploaded the readMifare and the busy light blinks once when the serial monitor is started but no readout. The readMifareClassic says Hello! then Didn't find PN53x board. in neither case did it blink when the tag was near the antenna.

I'm running the IDE on a Mint13 laptop.

What should I try next?
RayBATL
 
Posts: 6
Joined: Thu Sep 27, 2012 10:40 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Wed Nov 28, 2012 8:22 am

I have an Uno 1.0 so it doesn't have a pin for IOref. Do I need to do something with that pin on my shield?

Make sure you have the headers alighend properly. You should have 2 extra pins hanging over the end of the header on both sides. IOREF and an unmarked pin near "Reset" and SCL and SDA near "AREF" on the other side. These are redundant pins added to R3 boards for compatibility between UNO and MEGA. You do not need these pins for operation, but they are exposed, so make sure they are not shorting out against anything.
User avatar
adafruit_support_bill
 
Posts: 31029
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by RayBATL on Wed Nov 28, 2012 7:34 pm

I did not put pins in those holes since they didn't have anything to plug in to on the board.
RayBATL
 
Posts: 6
Joined: Thu Sep 27, 2012 10:40 pm

Re: NFC Shield - Didn't find PN53x board

by RayBATL on Sat Dec 01, 2012 6:53 am

Any suggestions on next steps for troubleshooting? I double checked the header connections and reloaded the sketch. I still get didn't find PN53x. I have extremely low coding skills but is there a debugging routine I can load to test it. Or meter readings I can take from test points. I do enjoy learning this way. Thanks.
RayBATL
 
Posts: 6
Joined: Thu Sep 27, 2012 10:40 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_rick on Sat Dec 01, 2012 2:18 pm

The 'busy' light blinks once and then goes out?
Please post detailed pictures of both sides of the shield. The ones earlier in the thread are good examples of what we need to see.

adafruit_support_rick
 
Posts: 13061
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: NFC Shield - Didn't find PN53x board

by RayBATL on Sun Dec 02, 2012 3:10 pm

No the busy light blinks off and then stays on.
Attachments
NFC_Shield_Front_0_r.JPG
NFC_Shield_Front_0_r.JPG (178.54 KiB) Viewed 1703 times
NFC_Shield_Back_0_r.JPG
NFC_Shield_Back_0_r.JPG (116.8 KiB) Viewed 1703 times
RayBATL
 
Posts: 6
Joined: Thu Sep 27, 2012 10:40 pm

Re: NFC Shield - Didn't find PN53x board

by RayBATL on Sun Dec 02, 2012 3:12 pm

Close ups.
Attachments
NFC_Shield_Front_2_r.JPG
NFC_Shield_Front_2_r.JPG (123.49 KiB) Viewed 1703 times
NFC_Shield_Front_1_r.JPG
NFC_Shield_Front_1_r.JPG (174.84 KiB) Viewed 1703 times
RayBATL
 
Posts: 6
Joined: Thu Sep 27, 2012 10:40 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_rick on Mon Dec 03, 2012 11:17 am

What happened here?
bewareoftheblob.png
bewareoftheblob.png (351.31 KiB) Viewed 1647 times

It looks like a short - maybe a stray blob of solder? See if you can gently scrape it away with an x-acto knife or other delicate instrument of destruction.

As long as that 'busy' light is lit, the sketch will keep telling you that it can't find the board. If that really is a short, it's in a place where it might cause the board to think that it's 'busy'.

adafruit_support_rick
 
Posts: 13061
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: NFC Shield - Didn't find PN53x board

by RayBATL on Mon Dec 03, 2012 11:27 pm

It came right off but it was too little to get my meter probes on. The solder joint under it looks intact but not very solid. I have a needle tip for my soldering iron but I have never attempted any surface mount soldering. Do you think it needs it.

After removing I tried running the program but no change. Still does not find the chip and the busy light stays on.
Attachments
NFC_Shield_Clean_0_r.jpg
NFC_Shield_Clean_0_r.jpg (52.96 KiB) Viewed 1637 times
RayBATL
 
Posts: 6
Joined: Thu Sep 27, 2012 10:40 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_rick on Tue Dec 04, 2012 11:28 am

That was the only potential problem I saw. Contact support@adafruit.com for a replacement. Reference this thread and include your original order number.

adafruit_support_rick
 
Posts: 13061
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: NFC Shield - Didn't find PN53x board

by geraldh on Wed Jan 02, 2013 2:48 am

I received a replacement PN532 in the mail, soldered the pins on and set it into my UNO R3. I am still getting a "didnt find PN53x board". I can't see how I have two defective boards that were obviously in two different batches. I uploaded the readmifare and even tried all the others. I made sure to change the baud rate to what was needed. The only thing that is different on mine versus the pics you have on here is that I have the SCL pin in place. Any other ideas as to what is going on here?
geraldh
 
Posts: 6
Joined: Fri Oct 19, 2012 2:14 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_rick on Wed Jan 02, 2013 12:21 pm

Are you using the I2C library or the SPI library? You should be using the I2C library

adafruit_support_rick
 
Posts: 13061
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: NFC Shield - Didn't find PN53x board

by geraldh on Wed Jan 16, 2013 2:56 am

Thank you! After fiddling with the libraries for a while I finally got it to take and recognize the card. I was hoping that maybe that was the problem with the original PN532 shield, but it still refuses to work, but all is good with the replacement, thanks for your help!
geraldh
 
Posts: 6
Joined: Fri Oct 19, 2012 2:14 pm

Re: NFC Shield - Didn't find PN53x board

by mko2013 on Thu Feb 28, 2013 8:42 am

I have recently purchased the adafruit pn532 rfid/nfc shield 13.56 Mhz and get this same problem "didn't find pn53x board".
(note: I am using arduino uno r3).

Looked at the readMifare code, getFirmwareversion() returns 0.0. What's wrong with my rfid card?

geraldh, is it possible to have you share your solution?

Many thanks!!
mko2013
 
Posts: 12
Joined: Thu Feb 28, 2013 8:33 am