NFC Shield - Didn't find PN53x board
Moderators: adafruit_support_bill, adafruit

NFC Shield - Didn't find PN53x board

by Jenesis on Sun Oct 21, 2012 5:45 pm

Hi there,

I'm trying to get the NFC shield to talk to my Arduino Uno R3, to no avail. All of the example programs in the Adafruit_NFCShield_I2C give me the 'Didn't find PN53x board' message. I've double-checked all my solder joints, and they all seem fine. I'm following the Babelfish tutorial, so I've cut the line from Digital I/O pin 2 to the IRQ, and wired the IRQ to pin 6 instead. I'm out of ideas. Any suggestions?
Jenesis
 
Posts: 6
Joined: Sun Oct 21, 2012 5:39 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Mon Oct 22, 2012 5:43 am

If you post photos of the front & back of the shield we'll take a look too.
User avatar
adafruit_support_bill
 
Posts: 31079
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by Jenesis on Mon Oct 22, 2012 3:53 pm

Photos as requested. They're a bit heavy on the solder (it's been a long time since I picked up a soldering iron), but I've reheated all the joints and they seemed to be flowing nicely.

IMAG0231.jpg
IMAG0231.jpg (1023.47 KiB) Viewed 2580 times
IMAG0232.jpg
IMAG0232.jpg (951.87 KiB) Viewed 2580 times
Jenesis
 
Posts: 6
Joined: Sun Oct 21, 2012 5:39 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Mon Oct 22, 2012 4:05 pm

That looks OK. Do you see any LEDs light up when you power the board?
User avatar
adafruit_support_bill
 
Posts: 31079
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by Jenesis on Tue Oct 23, 2012 5:22 am

Yeah, the green power light comes on and stays on, the red busy light comes on briefly and then goes out.
Jenesis
 
Posts: 6
Joined: Sun Oct 21, 2012 5:39 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Tue Oct 23, 2012 6:41 am

the red busy light comes on briefly and then goes out.

What sketch are you running? Try it with ReadMiFare.
User avatar
adafruit_support_bill
 
Posts: 31079
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by Jenesis on Wed Oct 24, 2012 4:17 pm

I tried it with all the sketches in the Adafruit_NFCShield_I2C examples, they all show the red light for a while. I've just tried them all again, including ReadMiFare again, same result. mifareclassic_memdump actually had the busy light on until I opened up the serial monitor.

On a more positive note, now that I've got my stacking headers I've tested the Wave Shield, and that's working fine.
Jenesis
 
Posts: 6
Joined: Sun Oct 21, 2012 5:39 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Wed Oct 24, 2012 4:27 pm

Something is wrong with it then. With the ReadMifare sketch, the busy light should be steady on - with a slight flicker when it detects a tag.

Contact support@adafruit.com with a link to this thread and ask for a replacement.
User avatar
adafruit_support_bill
 
Posts: 31079
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by geraldh on Wed Nov 07, 2012 4:10 am

I am having the same issue, all my solder joints are good. I made sure the libraries are correct, and used the mifare classic format sketch. I noticed that in the youtube video that the pins SCL and SCA were not included in the soldering, I have tried both with and without those pins. I have also read the question of using SC2 or SPI come up often. Is there a way to select which method to use, or is it dictated by the version of Arduino that I have?The Shield that I have is version 1.0, not sure if that matters but I have seen a version 1.3 as well. when I plug in the power to the Arduino, the pwr and busy LED's come on and the the busy LED turns of for a moment, and then turns back on permanently.
geraldh
 
Posts: 6
Joined: Fri Oct 19, 2012 2:14 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Wed Nov 07, 2012 7:42 am

@geraldh -
The board is configured by default for I2C communication. The example sketches assume I2C also.
Post photos of the front and back of the board. And describe what you see in the serial output when you run the ReadMifare sketch.
User avatar
adafruit_support_bill
 
Posts: 31079
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by geraldh on Thu Nov 08, 2012 1:34 am

top.jpg
top.jpg (137.71 KiB) Viewed 2399 times
bottom02.jpg
bottom02.jpg (87.83 KiB) Viewed 2399 times
bottom01.JPG
bottom01.JPG (81.66 KiB) Viewed 2399 times

When I run the serial window, and reset the arduino, it says:
Looking for PN532...
Didn't find PN53x board
geraldh
 
Posts: 6
Joined: Fri Oct 19, 2012 2:14 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Thu Nov 08, 2012 7:17 am

What kind of Arduino are you using? Do you see any led activity on the shield?
User avatar
adafruit_support_bill
 
Posts: 31079
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by geraldh on Thu Nov 08, 2012 1:13 pm

I'm using a UNO R3, the PWR LED lights continuously from the start, and the busy LED lights up turns off for a moment, and then back on continuously. It does not flicker at all when I place a RFID tag within proximity.
geraldh
 
Posts: 6
Joined: Fri Oct 19, 2012 2:14 pm

Re: NFC Shield - Didn't find PN53x board

by adafruit_support_bill on Thu Nov 08, 2012 1:43 pm

Is this while running the ReadMifare sketch?
User avatar
adafruit_support_bill
 
Posts: 31079
Joined: Sat Feb 07, 2009 10:11 am

Re: NFC Shield - Didn't find PN53x board

by geraldh on Thu Nov 08, 2012 8:35 pm

Yes, I tried all the other sketches in the examples folder. Some of the others would give the same results in the serial viewer, while a few others would just say nothing in the serial viewer.
geraldh
 
Posts: 6
Joined: Fri Oct 19, 2012 2:14 pm