Motorshield Question/Replacement motors
Moderators: adafruit_support_bill, adafruit

Motorshield Question/Replacement motors

by BBsan on Tue Jan 29, 2013 5:10 pm

Hi everybody,

I'm currently working on an arduino-raspberry pi based RC car.
My only problem left is, that I'm not able to drive curves with my motors.
Everytime I try to do it, I just get weird beeping noise. Adjusting frequencies doesn't change that.
I'm using 6 AA 1.5V cells to power the adafruit motorshield.

Do you have any suggestions how I can achieve a better driving?

If not - do you have any idea where I can get usable motors in short time? I'm from Germany.
The currently used motors where bundled with my Alu Robot Platform from sainsmart.
They are quiete similar to those: http://dx.com/p/dual-axis-reducer-motor ... -6v-185017
I'm not sure, how I can replace the motors, because they have kind of a transmission. (The yellowish around)

Any suggestions?

Greets
BBsan
BBsan
 
Posts: 4
Joined: Tue Jan 29, 2013 4:47 pm

Re: Motorshield Question/Replacement motors

by adafruit_support_bill on Tue Jan 29, 2013 6:03 pm

Check near the bottom of the FAQ. There are some recommendations pertaining to motors from a similar 4WD platform. Many users have reported similar problems of erratic behavior that we were able to trace to motor brush-noise.
http://learn.adafruit.com/adafruit-motor-shield/faq
User avatar
adafruit_support_bill
 
Posts: 31900
Joined: Sat Feb 07, 2009 10:11 am

Re: Motorshield Question/Replacement motors

by BBsan on Tue Jan 29, 2013 6:42 pm

Thank you very much:)

The FaQ says, that I need noise suppression capacitors.
Which parameters do I need to get them?
BBsan
 
Posts: 4
Joined: Tue Jan 29, 2013 4:47 pm

Re: Motorshield Question/Replacement motors

by adafruit_support_bill on Wed Jan 30, 2013 7:00 am

User avatar
adafruit_support_bill
 
Posts: 31900
Joined: Sat Feb 07, 2009 10:11 am

Re: Motorshield Question/Replacement motors

by BBsan on Thu Jan 31, 2013 5:12 am

Thanks a lot. I ordered some of these, they will hopefully solve my problems ;)
BBsan
 
Posts: 4
Joined: Tue Jan 29, 2013 4:47 pm

Re: Motorshield Question/Replacement motors

by BBsan on Tue Feb 05, 2013 11:21 am

OK little update..
I soldered the capacitors as mentioned above.
Now the strange beeping for low speed is gone - but the motors still don't turn.

Example:
PWM at 64Khz
Speed about 75 - Motors do only turn, if theres now load.
If it put the vehicle on the ground, the motors simply stop turning.
Any suggestions what I can do?
BBsan
 
Posts: 4
Joined: Tue Jan 29, 2013 4:47 pm

Re: Motorshield Question/Replacement motors

by adafruit_support_bill on Tue Feb 05, 2013 11:53 am

What are the motor specifications? You are running them at 9v now, can they handle more?

Try a lower PWM frequency. Also, some gear-motors benefit from a little light oil in the geartrain.
User avatar
adafruit_support_bill
 
Posts: 31900
Joined: Sat Feb 07, 2009 10:11 am