looks like I have a bad LCD display
Moderators: adafruit_support_bill, adafruit

looks like I have a bad LCD display

by segrest on Fri Feb 15, 2013 8:41 pm

Greetings Adafruit Support,

I received my RGB LCD Shield Kit w/ 16x2 Character Display kit today (https://www.adafruit.com/products/714) and assembled it without any difficulty.

My intent is to mount it in a plastic enclosue and use it in a detached configuration so I left all of the headers off except for the on that interfaces the LCD panel to the interface board. I also elected to mount the contrast pot on the back side of the interface board to facilitate a better fit to the cut out in my enclosure.

I applied power and immediately noticed that there was no backlight. I adjusted the contrast pot as instructed. At one extream The display is a solid black field. At the other extream each cell in the upper row of the display is a clear rectangle.

I have tried alternate power leads with no change in symptom. I checked the supply voltages with an osciliscope and it reads 5v.

LCD Shield.jpg
LCD Shield.jpg (94.67 KiB) Viewed 416 times


Any ideas?

How do I get this fixed?

Bob
segrest
 
Posts: 3
Joined: Fri Feb 15, 2013 8:18 pm

Re: looks like I have a bad LCD display

by adafruit_support_bill on Sat Feb 16, 2013 7:46 am

That looks normal for an initial power-up. The backlight is under software control and does not come on until the command is sent. Connect to your microprocessor and run one the example code to complete the test.
User avatar
adafruit_support_bill
 
Posts: 32643
Joined: Sat Feb 07, 2009 10:11 am

Re: looks like I have a bad LCD display

by segrest on Sat Feb 16, 2013 9:25 am

Code is required to turn the backlight on?

Really?

Bob
segrest
 
Posts: 3
Joined: Fri Feb 15, 2013 8:18 pm

Re: looks like I have a bad LCD display

by adafruit_support_bill on Sat Feb 16, 2013 9:54 am

Really! :D
User avatar
adafruit_support_bill
 
Posts: 32643
Joined: Sat Feb 07, 2009 10:11 am

Re: looks like I have a bad LCD display

by segrest on Mon Feb 18, 2013 6:14 pm

Thank you,

That got me where I need to be!

Bob
segrest
 
Posts: 3
Joined: Fri Feb 15, 2013 8:18 pm



cron