Problem using Adafruit_RGBLCDShield with Arduino Due
Moderators: adafruit_support_bill, adafruit

Problem using Adafruit_RGBLCDShield with Arduino Due

by nataku on Sat Feb 15, 2014 6:01 pm

Hi I am having problem compiling my program for Arduino Due when trying to include the Adafruit RGBLCDShield.
I have used this shield in the past with Uno and it works just fine.

This is the error I received.

/Users/adimulawarman/Documents/Arduino/libraries/Adafruit_RGBLCDShield/Adafruit_MCP23017.cpp:15: fatal error: avr/pgmspace.h: No such file or directory
compilation terminated.

I am not sure if the Due is supported so I downloaded the latest Github library files you guys have for this shield, delete the old library and unzipped the library into the user folder. Restart the Arduino IDE and still the same error. This error is the same when I am running the examples included in the library.

When I changed the board to Uno type, then the error is not there and everything compiled fine.

Is there anything that I am missing. I am including my ino file (rename to TXT) so you can see what I am trying to do. Pretty simple at the moment.
Attachments
MyMoistureSensor_DueVersion_v2.TXT
(3.52 KiB) Downloaded 1 time
nataku
 
Posts: 32
Joined: Sun Feb 17, 2013 12:09 am

Re: Problem using Adafruit_RGBLCDShield with Arduino Due

by franklin97355 on Sun Feb 16, 2014 1:04 am

I am not sure if the Due is supported
From your error I would say not but I'm not the one who knows for sure.
User avatar
franklin97355
 
Posts: 5420
Joined: Mon Apr 21, 2008 2:33 pm

Re: Problem using Adafruit_RGBLCDShield with Arduino Due

by nataku on Sun Feb 16, 2014 9:17 am

That is what I thought at first but the Github latest comment on the files says support/compatible for Due added. So I thought it should work.
nataku
 
Posts: 32
Joined: Sun Feb 17, 2013 12:09 am

Re: Problem using Adafruit_RGBLCDShield with Arduino Due

by nataku on Sun Feb 16, 2014 10:21 am

Problem solved by downloading latest IDE 1.5.5
It may be good to put a note in Github that the library will work with which version of the IDE.

Thanks for all the good works guys.
nataku
 
Posts: 32
Joined: Sun Feb 17, 2013 12:09 am

Re: Problem using Adafruit_RGBLCDShield with Arduino Due

by adafruit_support_mike on Sun Feb 16, 2014 6:01 pm

What version of the IDE were you using previously?
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 10051
Joined: Thu Feb 11, 2010 2:51 pm

Re: Problem using Adafruit_RGBLCDShield with Arduino Due

by nataku on Mon Feb 17, 2014 9:52 pm

1.5.2
nataku
 
Posts: 32
Joined: Sun Feb 17, 2013 12:09 am

Re: Problem using Adafruit_RGBLCDShield with Arduino Due

by adafruit_support_mike on Tue Feb 18, 2014 12:45 am

Hmm..

The 1.5.x series is still experimental, but it is where most of the Due support lives. We generally advise people to stick with the latest stable version (currently 1.0.5), but that isn't always an option for people using the Due. Honestly, Due support is kind of spotty right now, and will probably remain so until the 1.5.x branch becomes stable.
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 10051
Joined: Thu Feb 11, 2010 2:51 pm