cc3000 wifi shield port listening not working
Moderators: adafruit_support_bill, adafruit

cc3000 wifi shield port listening not working

by Peter van C on Tue Feb 18, 2014 8:38 pm

Hi adafruit,

With standard buildtest sketch I do het connection with my network but I'm missing something……..


SSID Name : VoGGi
RSSI : 34
Security Mode: 3

================================================

Deleting old connection profiles

Attempting to connect to Gastnetwerk van pvc4
Connected!
Request DHCP

IP Addr: 172.16.42.5
Netmask: 255.255.255.0
Gateway: 172.16.42.1
DHCPsrv: 172.16.42.1
DNSserv: 172.16.42.1
http://www.adafruit.com -> 207.58.139.247

Pinging 207.58.139.247...5 replies
Ping successful!


Closing the connection
Peter van C
 
Posts: 3
Joined: Tue Feb 18, 2014 8:27 pm

Re: cc3000 wifi shield port listening not working

by adafruit_support_mike on Tue Feb 18, 2014 11:53 pm

That's the correct output for the buildtest sketch. What problem are you having?
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 10218
Joined: Thu Feb 11, 2010 2:51 pm

Re: cc3000 wifi shield port listening not working

by Peter van C on Wed Feb 26, 2014 7:20 pm

Oke but when I do use thé adafruit webClient I do get this result

Connecting to Gast P....Waiting to connect...Connected!
Request DHCP

IP Addr: 192.168.42.2
Netmask: 255.255.255.0
Gateway: 192.168.42.1
DHCPsrv: 192.168.42.1
DNSserv: 172.16.42.1
www.adafruit.com ->

I do have to say that I'm using an Apple-extreme coneccted to my cable-modum.
What can be the problem.
Peter van C
 
Posts: 3
Joined: Tue Feb 18, 2014 8:27 pm

Re: cc3000 wifi shield port listening not working

by adafruit_support_mike on Fri Feb 28, 2014 1:34 am

According to that output, your CC3000 is making a connection to the wireless router and getting a connection, but the DNS lookup is failing. That probably has more to do with your wireless router than the CC3000 itself.

Check the router's status/settings pane to see how it handles DNS.
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 10218
Joined: Thu Feb 11, 2010 2:51 pm

Re: cc3000 wifi shield port listening not working

by Peter van C on Wed Mar 12, 2014 2:35 pm

Hardware: Arduino-Uno or Arduino-Mega with CC3000
Netwerk: Apple-Extreme router latest version connect Cablemodem.
After reinstall everything I can say that the problem with portforwarding on port 80 is NO PROBLEM at all.

This combination works now fine !
Peter van C
 
Posts: 3
Joined: Tue Feb 18, 2014 8:27 pm

Re: cc3000 wifi shield port listening not working

by adafruit_support_mike on Fri Mar 14, 2014 4:44 pm

Great! Glad to hear you have it working. ;-)
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 10218
Joined: Thu Feb 11, 2010 2:51 pm