can't verify 'touch paint' tutorial sketch

by smithh on Wed Feb 19, 2014 12:48 am

Bought a 2.8" TFT arduino shield and am going through the tutorials, they all worked until I got to the 'touch paint' sketch. The problem is wire.h can't be found. Attached or screen shots showing the problem.
Attachments
wire_prob.gif
wire_prob.gif (70.48 KiB) Viewed 93 times
wire_prob_path.gif
wire_prob_path.gif (87.67 KiB) Viewed 93 times
smithh
 
Posts: 4
Joined: Wed Jun 01, 2011 1:46 pm

Re: can't verify 'touch paint' tutorial sketch

by adafruit_support_bill on Wed Feb 19, 2014 7:28 am

Wire.h is part of the Arduino install. You shouldn't have to move it anywhere.

I see you are using 1.5.5 Beta. This is still Beta software. Unless you are programming a Yun or a Due, you should be using one of the full releases such as 1.0.5.
User avatar
adafruit_support_bill
 
Posts: 25556
Joined: Sat Feb 07, 2009 9:11 am

Re: can't verify 'touch paint' tutorial sketch

by smithh on Thu Feb 20, 2014 8:10 pm

OK. Loaded 1.0.5 IDE and got most of the tutorial to work. The 'touch paint' sketch isn't working. When uploaded it displays the color select menu then nothing. I modified the sketch and opened the serial monitor. See attachment. The shield is mounted on a Freetronics Eleven non R3 (UNO), which shouldn't be a problem.
Attachments
ts.gif
ts.gif (47.07 KiB) Viewed 58 times
smithh
 
Posts: 4
Joined: Wed Jun 01, 2011 1:46 pm

Re: can't verify 'touch paint' tutorial sketch

by adafruit_support_bill on Fri Feb 21, 2014 5:54 am

This is the V2 Touch Shield, correct? What do you get for output when running the TouchTest sketch from the STMPE610 library?

Use the Hardware SPI option, with pin 8 for CS:

Code: Select all
// Option #2 - use hardware SPI, connect to hardware SPI port only!
// SDI to MOSI, SDO to MISO, and SCL to SPI CLOCK
// on Arduino Uno, that's 11, 12 and 13 respectively
// Then pick a CS pin, any pin is OK but we suggest #10 on an Uno
// tie MODE to 3.3V and POWER CYCLE the STMPE610 (there is no reset pin)

Adafruit_STMPE610 touch = Adafruit_STMPE610(8);
User avatar
adafruit_support_bill
 
Posts: 25556
Joined: Sat Feb 07, 2009 9:11 am

Re: can't verify 'touch paint' tutorial sketch

by smithh on Fri Feb 21, 2014 5:00 pm

Yes. I have the V2 shield.
the screen turns white and nothing happens. I'm using a stylus for touching.

ts2.gif
ts2.gif (7.47 KiB) Viewed 40 times


ts1.gif
ts1.gif (6.49 KiB) Viewed 40 times
smithh
 
Posts: 4
Joined: Wed Jun 01, 2011 1:46 pm

Re: can't verify 'touch paint' tutorial sketch

by adafruit_support_bill on Fri Feb 21, 2014 7:31 pm

OK. If you contact support@adafruit.com with a link to this thread we can send you a replacement.
User avatar
adafruit_support_bill
 
Posts: 25556
Joined: Sat Feb 07, 2009 9:11 am

Re: can't verify 'touch paint' tutorial sketch

by smithh on Tue Mar 04, 2014 6:03 am

Just a note to say thank you for the prompt service on the new shield. I received it plugged in and turned it on narrowing runs just fine you do provide good service thank you very much.

Hugh Smith
smithh
 
Posts: 4
Joined: Wed Jun 01, 2011 1:46 pm