xbee setup with adapter kit
Moderators: adafruit_support_bill, adafruit

xbee setup with adapter kit

by johncarl81 on Wed Dec 26, 2012 9:28 pm

I soldered two xbee adapter kits (http://adafruit.com/products/126) today and was planning on connecting two Arduinos via the xbee serial connection.

When I connect the xbee adapters to the 5v/Ground pins I get a solid green light. Reading the instructions, it seems the green light is supposed to flash. Does a solid light mean something is wrong? I cannot seem to send or receive serial data via the xbees.

Also, I was hoping to get things up and running without having to configure the xbees with X-CTU. Do I have to configure the xbee modules to allow them to correctly work? If they do require configuration, can they be configured through a chip-less Arduino (instructions at the end of this page: http://www.ladyada.net/make/xbee/wiring.html)?

Thanks.

John
johncarl81
 
Posts: 3
Joined: Tue Dec 18, 2012 6:09 pm

Re: xbee setup with adapter kit

by adafruit_support_rick on Wed Dec 26, 2012 11:52 pm

According to the tutorial page:
Some versions of XBees the green LED doesnt blink, but it is on.


The first section of the tutorial tells yu how to configure the XBee using Hyperterm or any other terminal emulator program. You don't have to use X-CTU

adafruit_support_rick
 
Posts: 13839
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: xbee setup with adapter kit

by johncarl81 on Thu Dec 27, 2012 1:44 am

Ok, I was able to setup the firmware after re-reading the tutorial. The green LEDs are blinking, and both are setup to run on the same PAN ID. The problem is now that I cant seem to get them to exchange data. Is there something special I need to configure to get the XBee v2 (non-pro) to communicate?
johncarl81
 
Posts: 3
Joined: Tue Dec 18, 2012 6:09 pm

Re: xbee setup with adapter kit

by johncarl81 on Thu Dec 27, 2012 2:03 am

Victory. Got it working. Seems that I was missing the DH and DL parameters on the COORDINATOR AT module as described in the arduino docs: http://arduino.cc/en/Guide/ArduinoWirelessShieldS2 .
johncarl81
 
Posts: 3
Joined: Tue Dec 18, 2012 6:09 pm

Re: xbee setup with adapter kit

by adafruit_support_rick on Thu Dec 27, 2012 11:23 am

Great!

adafruit_support_rick
 
Posts: 13839
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY