Ice Tube unplug power what to expect?

by ib123 on Sun Aug 14, 2011 2:11 pm

I've searched for information about the normal operation of the Ice Tube clock but I can't find it anywhere, so I'm asking here.

What is expected to happen if I unplug the power adapter for a short while and then restore power? I'm not sure if my clock is working right and want to check.

For me, when I restore power to the clock the display starts blinking and the seconds advance two at a time. The clock also seems to lose several minutes of time while unplugged but it doesn't reset completely. I've checked the backup battery and it reads 3.17 V, which I think is good.

When power is present all the functions of the clock work as expected and it keeps good time.

Before I start trying to diagnose problems, can someone tell me how a properly working clock should behave on loss of power?
ib123
 
Posts: 11
Joined: Sun Aug 14, 2011 2:02 pm

Re: Ice Tube unplug power what to expect?

by adafruit_support_bill on Sun Aug 14, 2011 2:35 pm

The battery should allow the clock to keep time for a few weeks while un-powered.
Did you remember to add a blob of solder under the battery in this step?

Image
User avatar
adafruit_support_bill
 
Posts: 25601
Joined: Sat Feb 07, 2009 9:11 am

Re: Ice Tube unplug power what to expect?

by ib123 on Sun Aug 14, 2011 2:44 pm

Yes, I added the blob of solder and checked with my finger that it was raised slightly above the level of the circuit board.

Should I understand the display is not supposed to be blinking when power is restored?
ib123
 
Posts: 11
Joined: Sun Aug 14, 2011 2:02 pm

Re: Ice Tube unplug power what to expect?

by ib123 on Sun Aug 14, 2011 2:52 pm

If the display is not supposed to be blinking it appears I should check that 3 V appears across the battery holder and at C4 when the battery is inserted.

From looking at the design the battery negative could be shorted to the battery holder if the solder blob is not raised high enough...?
ib123
 
Posts: 11
Joined: Sun Aug 14, 2011 2:02 pm

Re: Ice Tube unplug power what to expect?

by ib123 on Sun Aug 14, 2011 4:19 pm

I unplugged the power adapter and took the case apart for measurements. The voltage on the battery holder and on both sides of D4 is about 3.2 V, however the voltage was dropping by about 4 mV per minute. That seemed a little high to me.

However, when I restored power to the clock the time was still good. I'm not sure what might have happened previously.

I would still appreciate if you could answer my questions from the first post:

When I restore power after a short period on the backup battery, what should happen?
Should the clock beep?
Should the display start blinking?

I think this information would be helpful if added to the user instructions under 'daily use'. It is confusing if you don't know what the clock is meant to be doing.
ib123
 
Posts: 11
Joined: Sun Aug 14, 2011 2:02 pm

Re: Ice Tube unplug power what to expect?

by skylerin on Tue Aug 16, 2011 8:25 pm

The behavior of the clock after restoring power can be seen in this video:

http://www.youtube.com/watch?v=Fqw9x9WRRbE
skylerin
 
Posts: 4
Joined: Wed Jul 06, 2011 6:01 pm

Re: Ice Tube unplug power what to expect?

by ib123 on Tue Aug 16, 2011 10:25 pm

OK, thanks. I was guessing by the deathly silence from Adafruit that my observed behavior is what it was designed to so.

The design is, however, a little puzzling. I would think it better if the display only started flashing if the clock discovered a loss of time keeping due to a failed backup battery. If the backup battery maintained a good voltage the clock could just come right back without any beeping or flashing. Why alarm people when there is no cause for alarm?

Oh well, I guess there will be an incentive to download the program and play with it some time...
ib123
 
Posts: 11
Joined: Sun Aug 14, 2011 2:02 pm

Re: Ice Tube unplug power what to expect?

by jarchie on Mon Dec 03, 2012 9:53 pm

This is probably the issue that prompted me to rewrite the official Ice Tube Clock firmware. For those interested in writing a no-reset-on-power-failure firmware, I've posted some advice in the thread entitled "Ice Tube Firmware Question" in this (the "Clocks") forum.

(Sorry for the duplicate post, but this is one of the threads I found when trying to ascertain how to remove the reset-on-power-failure behavior. So I figured, I should at least post something here.)
--John <www.jarchie.com/email>
jarchie
 
Posts: 331
Joined: Sun Jun 24, 2012 1:16 pm
Location: Santa Cruz, California, United States