Ice Tube Clock - Digit 3 not lighting
Moderators: adafruit_support_bill, adafruit

Ice Tube Clock - Digit 3 not lighting

by philmonty on Sat Aug 25, 2012 9:18 pm

Firstly, thanks for building such a great kit - my son and I had a great time building it, and everything went fine until the end point, where we noticed digit 3 is not lighting.

I've spent about 4 hours reading this forum, and trying all the things suggested.

We've gone back and reflowed all the solder numerous times
Checked the continuity to the VFD driver of VFD3 (perfect)
There is voltage on pin 21 of the tube.
Tried shorting another working pin over to pin 21, with no luck.

I actually like that this kit has forced us to troubleshoot and learn more about the circuit.

What should I do next?
Attachments
2012-08-25 18.02.17.jpg
Looks messy, but that is flux
2012-08-25 18.02.17.jpg (36.86 KiB) Viewed 2310 times
2012-08-25 18.01.59.jpg
Soldering PCB
2012-08-25 18.01.59.jpg (44.29 KiB) Viewed 2310 times
2012-08-25 18.01.15.jpg
Showing missing digital (3rd from left)
2012-08-25 18.01.15.jpg (34.91 KiB) Viewed 2310 times

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm

Re: Ice Tube Clock - Digit 3 not lighting

by adafruit_support_bill on Sun Aug 26, 2012 6:59 am

It looks like you have a 22 pin tube, correct?
Can you get a clearer shot of the tube-board and indicate the pin you have identified as 21?
If you size it to about 800x600 we can see more detail.
User avatar
adafruit_support_bill
 
Posts: 31841
Joined: Sat Feb 07, 2009 10:11 am

Re: Ice Tube Clock - Digit 3 not lighting

by philmonty on Sun Aug 26, 2012 2:44 pm

Yes, a 22pin tube. I used the document on the download page to figure out 6,7,8 were not connected, so just counted around from there. I don't have a very good digital camera, and this is blurry, but is what I identified as pin 21.
Attachments
1-2012-08-26 10.39.36.jpg
screwdriver points to pin 21
1-2012-08-26 10.39.36.jpg (25.69 KiB) Viewed 2284 times

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm

Re: Ice Tube Clock - Digit 3 not lighting

by philmonty on Sun Aug 26, 2012 2:44 pm

P.S. Is there any sort of reference that shows the tube pin numbers as per the PCB?

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm

Re: Ice Tube Clock - Digit 3 not lighting

by philmonty on Sun Aug 26, 2012 2:51 pm

Actually, I just looked further into the Tube document, and it states that pin 19 is the one that drives my missing digit. I just measured the voltage at pin 19 and it is zero, so I assume that's my problem.

I need to head to a conference for 3-4 days, so don't have time to troubleshoot now, but could someone clarify to me exactly connection/pin to troubleshoot to solve my missing digit? Much appreciated.

Phil

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm

Re: Ice Tube Clock - Digit 3 not lighting

by john444 on Sun Aug 26, 2012 2:52 pm

Hi Phil,

Even a low resolution camera benefits from good lighting.
Try taking the whole thing outside in the sunlight.
Good photos will help to make this much easier.

John
john444
 
Posts: 443
Joined: Sun Mar 04, 2012 2:42 pm
Location: Claremore, Ok

Re: Ice Tube Clock - Digit 3 not lighting

by philmonty on Sun Aug 26, 2012 3:07 pm

Thanks for the reply John, and I did as you asked. Let me know if any more pics are needed.
Attachments
1-2012-08-26 12.04.25.jpg
1-2012-08-26 12.04.25.jpg (277.86 KiB) Viewed 2281 times
1-2012-08-26 12.04.11.jpg
1-2012-08-26 12.04.11.jpg (340.28 KiB) Viewed 2281 times
1-2012-08-26 12.04.10.jpg
1-2012-08-26 12.04.10.jpg (341.77 KiB) Viewed 2281 times

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm

Re: Ice Tube Clock - Digit 3 not lighting

by philmonty on Sun Aug 26, 2012 3:08 pm

More pics
Attachments
1-2012-08-26 12.04.35.jpg
1-2012-08-26 12.04.35.jpg (295.85 KiB) Viewed 2281 times
1-2012-08-26 12.04.30.jpg
1-2012-08-26 12.04.30.jpg (165.28 KiB) Viewed 2281 times

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm

Re: Ice Tube Clock - Digit 3 not lighting

by adafruit_support_bill on Sun Aug 26, 2012 5:29 pm

Thanks, those pictures are much better.

I just measured the voltage at pin 19 and it is zero, so I assume that's my problem.

Does shorting it to an adjacent pin light the digit?
User avatar
adafruit_support_bill
 
Posts: 31841
Joined: Sat Feb 07, 2009 10:11 am

Re: Ice Tube Clock - Digit 3 not lighting

by john444 on Sun Aug 26, 2012 5:40 pm

Phil,

Much better photos! Thanks for going to the extra trouble.
Adafruit support has by far the most experience with such things and usually picks up on issues right away.
The only things I see (in the latest batch of photos),
there appears to be excess solder on the 'tube side' of the pc board.
And, probably not related but there may be a scratch through the trace that runs around the pc board (opposite the tube).

You can remove extra solder using solder-wick or apply extra flux and re-melt.
For the scratch in the pc board trace, carefully scrape the solder-mask to expose bright copper and bridge the gap with solder.

I am not sure which digit you indicated is #3.
Tube pin-19 appears to me to be digit-7, the un-used digit between the minutes & seconds.
philmonty wrote:P.S. Is there any sort of reference that shows the tube pin numbers as per the PCB?

From the schematic, Digit 3 (VFD3) is tube pin-16.

Good luck with the trouble-shooting.
John
VFD3 goes back to connector J2 pin-3.
Connector J2 pin-3 goes back to the MAX6921 pin-21.
You can keep checking back until the 30-60-v shows up.
When you find that spot, the problem is between where the v shows up and where it disappears.
john444
 
Posts: 443
Joined: Sun Mar 04, 2012 2:42 pm
Location: Claremore, Ok

Re: Ice Tube Clock - Digit 3 not lighting

by philmonty on Tue Aug 28, 2012 12:35 pm

Hi John

Thanks again for the reply. One thing that confuses me is that the design says the missing digit (7th from right, I think the schematic says it's digit 7) is pin 16 (VFD3), but the last page of the IW-18 tube schematic (http://www.tube-tester.com/sites/nixie/ ... /IV-18.pdf) says it's pin 19.

which one is it? Sort of tough to troubleshoot when you're not exactly sure.

All advice is welcome. Also, exactly where do you see the broken trace? I can't see it.

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm

Re: Ice Tube Clock - Digit 3 not lighting

by adafruit_support_bill on Tue Aug 28, 2012 12:59 pm

Are you counting pins from the solder-side or the tube-side of the board? I believe the diagram you linked is looking from the solder-side.
User avatar
adafruit_support_bill
 
Posts: 31841
Joined: Sat Feb 07, 2009 10:11 am

Re: Ice Tube Clock - Digit 3 not lighting

by john444 on Tue Aug 28, 2012 1:18 pm

Hi Phil,

john444 wrote:there may be a scratch through the trace that runs around the pc board
philmonty wrote:exactly where do you see the broken trace? I can't see it

I am not at all certain but refer to the photo for the location of the scratches on the trace.
1-2012-08-26%2012_04_30.jpg
1-2012-08-26%2012_04_30.jpg (161.98 KiB) Viewed 2247 times


Any luck following the voltage to the dead digit?
John
john444
 
Posts: 443
Joined: Sun Mar 04, 2012 2:42 pm
Location: Claremore, Ok

Re: Ice Tube Clock - Digit 3 not lighting

by adafruit_support_rick on Sat Sep 08, 2012 2:19 pm

I'm pretty sure the pin that controls that digit is pin 19 on the tube.

In the picture of the solder-side of the tube board, the two pins at the bottom of the picture, with the visible traces coming from either side, are pins 12 and 13. Numbering is clockwise.

So, you can see these traces in the picture, which check against the schematic:
    pin 2 of the 2X10 header connecting to tube-pin 13
    pin 4 of the 2X10 header connecting to tube-pin 15
    pin 20 of the 2X10 header connecting to tube-pin 12

You can count around to find tube pin 19, and that should connect to 2X10 header pin 8 (4th from left, top row in picture).

So, you should be able to check for continuity between header pin 8 and tube pin 19.
You should also have continuity between header pin 8 and pin 17 of the MAX6921 VFD controller.

You don't have voltage at tube pin 19? You should also check for voltage at header pin 8 and MAX6921 pin 17. If none of these places have voltage, then it's a bad MAX chip. Otherwise, it's a bad solder joint between the chip and the tube.

adafruit_support_rick
 
Posts: 13815
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Ice Tube Clock - Digit 3 not lighting

by philmonty on Sat Sep 08, 2012 9:02 pm

Thanks for the reply - I ended up finding a bad join on the J2 connector - I knew there was one when I picked up the board with my fingers across the pins, and the digit lit up very dimly :-)

Appreciate all the great assistance - now have a fabulous working clock.

Phil

philmonty
 
Posts: 25
Joined: Mon Jun 08, 2009 5:28 pm