monochron fails LED + switch test
Moderators: adafruit_support_bill, adafruit

monochron fails LED + switch test

by madducks on Sun Jan 13, 2013 5:22 pm

Hello,

I am very very new to soldering and kit building, before tackling the monochron I have only built the TV-B-Gone. I have been following the monochron instructions and everything has gone fine up until soldering the switch and LED. At that point when I plug it in I hear the beeps, but the LED will not turn on no matter what position the switch is in. I have posted pictures of my work so far, any help would be greatly appreciated.

Image
Image

Thank you,
Aric
madducks
 
Posts: 6
Joined: Thu Sep 27, 2012 1:55 pm

Re: monochron fails LED + switch test

by adafruit_support_rick on Sun Jan 13, 2013 7:45 pm

Difficult to see the solders on the IC socket because of the flash, but quite a few of the pins look solder-starved. Solders should look like this:
Solder%20Joint.gif
Solder%20Joint.gif (7.78 KiB) Viewed 959 times
. Try retouching any pins that look a little light. You might also review our Guide To Excellent Soldering

adafruit_support_rick
 
Posts: 12827
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: monochron fails LED + switch test

by madducks on Thu Jan 31, 2013 9:44 am

Hello, and thank you for help! It was a while before I had time to work on this again, thus the slow reply. I have reviewed that soldering tutorial and have resoldered not just the socket, but also the other components and my problem continues. I have triple/quadruple checked that the placement of the soldered components but the problem persists. I have also replaced the LED. Is there some way I might narrow down my problem?

Thank you again for your help.

-Aric
madducks
 
Posts: 6
Joined: Thu Sep 27, 2012 1:55 pm

Re: monochron fails LED + switch test

by adafruit_support_rick on Thu Jan 31, 2013 10:38 am

Could be a bad switch. Do you have a voltmeter/multimeter? Referring to the picture below:

- you should always see 5V between the pads labeled "+5V" and "GND".

- with the switch in the position shown:
- you should have continuity between "GND" and "switched GND/NC"
- you should see 5V between "+5V" and "switched GND/NC"

- with the switch in the opposite position:
- you should have continuity between "NC" and "switched GND/NC"
- you should see 0V between "+5V" and "switched GND/NC"

monochron_test_pts.png
test points
monochron_test_pts.png (322.81 KiB) Viewed 671 times

adafruit_support_rick
 
Posts: 12827
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: monochron fails LED + switch test

by madducks on Thu Jan 31, 2013 8:05 pm

Hello,

Thank you so much for your help, and thank you for keeping the kids gloves on!

I'm not sure what to make of this but here is what I observed:

I only ever saw 0 volts between +5V and GND, no matter the position of the switch.
I touched up the solder a bit, but still never saw anything between them.

Switch in position shown:
-0 between GND and switched GND/NC
5.08V between +5V and switched GND/NC

Opposite position:
-0 between NC and switched GND/NC
0.4 (fluctuated) between +5V and switched GND/NC

Thank you again for your help.
madducks
 
Posts: 6
Joined: Thu Sep 27, 2012 1:55 pm

Re: monochron fails LED + switch test

by adafruit_support_bill on Fri Feb 01, 2013 6:35 am

That would seem to indicate that you have a bad switch there. Contact support@adafruit.com with a link to this thread and ask for a replacement switch for your Monochron.
User avatar
adafruit_support_bill
 
Posts: 30794
Joined: Sat Feb 07, 2009 10:11 am

Re: monochron fails LED + switch test

by madducks on Fri Feb 01, 2013 8:33 am

Thank you for your help!
madducks
 
Posts: 6
Joined: Thu Sep 27, 2012 1:55 pm

Re: monochron fails LED + switch test

by madducks on Fri Feb 15, 2013 7:03 pm

You guys are awesome. Thanks to your help I now I have a fully functional monochron.

Image


Thank you!
madducks
 
Posts: 6
Joined: Thu Sep 27, 2012 1:55 pm

Re: monochron fails LED + switch test

by madducks on Fri Feb 15, 2013 7:05 pm

Not looking especially competent lately :) Try this link since the image wouldn't imbed:

https://www.dropbox.com/s/gmtbnsf82nb1kxd/2013-02-15%2017.57.21.jpg
madducks
 
Posts: 6
Joined: Thu Sep 27, 2012 1:55 pm

Re: monochron fails LED + switch test

by adafruit_support_rick on Fri Feb 15, 2013 7:22 pm

Hmmm ... I think you need to take some of those Legos and build a Monochron enclosure... :D

adafruit_support_rick
 
Posts: 12827
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY