128x32 i2c OLED connections? No light
Moderators: adafruit_support_bill, adafruit

128x32 i2c OLED connections? No light

by wesg on Fri Nov 30, 2012 8:56 pm

I'm just connecting my new 128x32 i2c OLED screen but so far following the detailed tutorial on the learning system haven't produced any light.

I'm using the standard demo code from GitHub, and have it wired up the same way as shown. At first the code was complaining about the value of SSD1306_LCDHEIGHT so I set it to define and it's uploaded fine.

Since I haven't changed any of the other code, I'm surprised it doesn't work correctly. Here are the initialization statements in the code. Where else should I check?

Code: Select all | TOGGLE FULL SIZE
#include <Wire.h>
#include <Adafruit_GFX.h>
#include <Adafruit_SSD1306.h>

#define OLED_RESET 4
Adafruit_SSD1306 display(OLED_RESET);

#define SSD1306_LCDHEIGHT 32
#define NUMFLAKES 10
#define XPOS 0
#define YPOS 1
#define DELTAY 2


#define LOGO16_GLCD_HEIGHT 16
#define LOGO16_GLCD_WIDTH  16
http://www.wesg.ca - Macs and more, including Arduinos!
MacBook Pro 13" - Mountain Lion
Ubuntu Server - Nimitz - 9.25TB
4.0 GHz i7-950 watercooled workstation
Arduino / Arduino MEGA / Arduino Pro MINI / Raspberry Pi
User avatar
wesg
 
Posts: 87
Joined: Thu Mar 18, 2010 10:00 pm
Location: Toronto, Ontario

Re: 128x32 i2c OLED connections? No light

by adafruit_support_rick on Sat Dec 01, 2012 2:43 pm

Can you post some pictures of your wiring and the breakout board?

adafruit_support_rick
 
Posts: 12886
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: 128x32 i2c OLED connections? No light

by wesg on Sat Dec 01, 2012 3:37 pm

Thanks, driver. This might be the best photo.

http://imgur.com/Fog35

As a map, the wires are:
SDA A4
SCL A5
RST Digital 4
GND GND
Vin +5V
http://www.wesg.ca - Macs and more, including Arduinos!
MacBook Pro 13" - Mountain Lion
Ubuntu Server - Nimitz - 9.25TB
4.0 GHz i7-950 watercooled workstation
Arduino / Arduino MEGA / Arduino Pro MINI / Raspberry Pi
User avatar
wesg
 
Posts: 87
Joined: Thu Mar 18, 2010 10:00 pm
Location: Toronto, Ontario

Re: 128x32 i2c OLED connections? No light

by wesg on Sat Dec 01, 2012 3:41 pm

OK, update! I think some of the wires were bad. I replaced the jumpers and now it's flashing away.

Note to others: verify your wires!
http://www.wesg.ca - Macs and more, including Arduinos!
MacBook Pro 13" - Mountain Lion
Ubuntu Server - Nimitz - 9.25TB
4.0 GHz i7-950 watercooled workstation
Arduino / Arduino MEGA / Arduino Pro MINI / Raspberry Pi
User avatar
wesg
 
Posts: 87
Joined: Thu Mar 18, 2010 10:00 pm
Location: Toronto, Ontario

Re: 128x32 i2c OLED connections? No light

by adafruit_support_rick on Sat Dec 01, 2012 3:43 pm

Great!

adafruit_support_rick
 
Posts: 12886
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY