Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

Problem with OLED 128x32 SPI
Moderators: adafruit_support_bill, adafruit

Problem with OLED 128x32 SPI

by bluszcz on Sun Feb 17, 2013 6:49 pm

Hey,

I purchased OLED 128x32 and the examples from Adarfuit_GFX work properly :)

However, I am trying to use it along with the sensor od DHT11 - and besides of the logo in setup() I am not able to display anything in the setup()

My code is here: http://pastebin.com/FKjh3AEB leds are working with other examples - so I am doing something wrong, help :shock:

Cheers,

bluszcz
bluszcz
 
Posts: 1
Joined: Mon Feb 11, 2013 9:18 am

Re: Problem with OLED 128x32 SPI

by adafruit_support_rick on Sun Feb 17, 2013 8:07 pm

I don't see where you have instantiated the DHT object, as is done in the example sketch, below:
Code: Select all | TOGGLE FULL SIZE
#include "DHT.h"

#define DHTPIN 2     // what pin we're connected to

// Uncomment whatever type you're using!
//#define DHTTYPE DHT11   // DHT 11
#define DHTTYPE DHT22   // DHT 22  (AM2302)
//#define DHTTYPE DHT21   // DHT 21 (AM2301)

// Connect pin 1 (on the left) of the sensor to +5V
// Connect pin 2 of the sensor to whatever your DHTPIN is
// Connect pin 4 (on the right) of the sensor to GROUND
// Connect a 10K resistor from pin 2 (data) to pin 1 (power) of the sensor

DHT dht(DHTPIN, DHTTYPE);   //Instantiate DHT object

adafruit_support_rick
 
Posts: 18426
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY