Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

Beaglebone. Help me with strange data loss issue.
Moderators: adafruit_support_bill, adafruit

Beaglebone. Help me with strange data loss issue.

by kennie.still on Thu Jul 26, 2012 3:04 pm

I just got my beaglebone in two days ago. Within a few hours my friend and I had lighttpd with php serving a basic webpage available externally on the internet. We were very pleased with our progress, and everything seemed to go as smoothly as is possible with a little bit of expected troubleshooting here and there.

It worked great at 1:00am today (I was getting the web page over 3G on my iphone). I went straight to sleep, and when I woke up the webpage wouldn't show up. Hmmm, strange. I ssh'd into the beaglebone and tried to run some basic commands. Lighttpd was gone. Sudo (which we had installed) was unrecognized, .conf files were missing. Everything was out of whack.

I didn't touch a thing. It went from working to not working all by itself in a few hours. What gives? Some of the stuff we did was still there (like the user I created and some files that I had ftp'd over).

What gives? How did all that data get lost all by itself? I thought linux was supposed to be stable? Am I going to reliably use this to control my sprinkler system? I'm a little upset with it. I can get over it if I broke it, but it seemed to break itself.
kennie.still
 
Posts: 1
Joined: Thu Jul 26, 2012 2:56 pm