No USB host?
Moderators: adafruit_support_bill, adafruit

No USB host?

by Marburg on Sat Aug 11, 2012 4:33 am

Just unpacked my minty-fresh Beaglebone. Things seemed to be going well (usb console, usb g_disk_storage and g_ether, ethernet), but it won't recognize USB devices on the A/Host port -- an Adafruit 802.11n network adaptor, a thumb drive and a couple of HID devices. All plugged in directly, all while on a 2A DC adaptor. Basically there's no activity (no dmesg, nothing on lsusb -v).

Won't have a powered hub handy until I raid my office come Monday, that seems like the obvious next thing to try.

This is after following the instructions from http://learn.adafruit.com/beaglebone/wifi, on kernel 3.2.25-r15a+gitr720e...... brought in by the opkg upgrade.

So, a bit stumped. Any obvious place to start on debugging?
Marburg
 
Posts: 3
Joined: Wed Nov 21, 2007 12:27 am

Re: No USB host?

by adafruit on Sat Aug 11, 2012 6:06 pm

you might want to check the beaglebone forums - this is a new one we've never heard before!
User avatar
adafruit
 
Posts: 11707
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: No USB host?

by Marburg on Sun Aug 12, 2012 4:38 am

Hm, I've made the ghost in the machine disappear through some combination of a hard power cycle, replugging the power adaptor, being a bit more careful about starting on the DC adaptor (I know, shouldn't make any difference) and general futzing it's all started working. Mysterious.

But, sadly, one of the two wifi adaptors has stopped working. Will have a bit more of a play with that ....
Marburg
 
Posts: 3
Joined: Wed Nov 21, 2007 12:27 am