Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

IOError: [Errno 2] No such file or directory
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

IOError: [Errno 2] No such file or directory

by hwiguna on Sun Aug 26, 2012 3:21 pm

I'm following along this tutorial on learn.adafruit.com.
http://learn.adafruit.com/matrix-7-segm ... pi-for-i2c

When I run the example:
sudo pytho ex_8x8_pixels.py

I receive this error:
IOError: [Errno 2] No such file or directory

Typing sudo i2cdetect -y 0 also returns a similar error:
Error: Could not open file '/dev/i2c-0' or '/dev/i2c/0': No such file or directory.

The installation of python-smbus and i2c-tools succeeded. What did I do wrong?

hwiguna
 
Posts: 15
Joined: Wed Nov 16, 2011 10:33 am

Re: IOError: [Errno 2] No such file or directory

by adafruit on Mon Aug 27, 2012 4:03 pm

are you using Occidentalis?

adafruit
 
Posts: 11905
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: IOError: [Errno 2] No such file or directory

by hwiguna on Tue Aug 28, 2012 9:48 pm

I was using Raspbian Wheezy and installed packages as outlined in the tutorial.
I've since tried Occidentalis, but my SD card (4GB PNY P-SDHC4G4-GE) doesn't like it. It failed during boot with:
PANIC: VFS: Unable to mount root fs on unknown-block(179,2)

I've checked the md5 on the .img. It matches, so it must be the card. I'll try imaging it from a Windows machine.

hwiguna
 
Posts: 15
Joined: Wed Nov 16, 2011 10:33 am

Re: IOError: [Errno 2] No such file or directory

by hwiguna on Fri Aug 31, 2012 11:09 pm

Finally got around to setting up Occidentalis from a Windows PC. The card kept saying that it's write protected eventhough it is clearly NOT in the lock position. Google found this thread about putting a tape over the write protect tab. It worked! Occidentalis is great! I was able to get the I2C to work out of the box. Thanks AdaFruit!

hwiguna
 
Posts: 15
Joined: Wed Nov 16, 2011 10:33 am