Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

WEBIDE AFTER SD CARD FAIL
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

WEBIDE AFTER SD CARD FAIL

by VOYAGERUSA on Tue Feb 12, 2013 11:16 pm

After installing new os after crash i get into installing webide up to the page where in asked to log into bitbucket account and a page with errors is returned [failed to obtain request token (status: 400 data: Invalid consumer.) is the first line of 15 lines.
can get into bit bucket account ok from google browser but fails when im trying to setup the webide from a computer other than the pi.
all was working ok untill crash and new instillation .
accepts the key and secret ok but the next page is where the errors come in.
i believe its a authentication problem .
have tried another computer thinking may be a browser cache problem but still not going into bitbucket from webide setup.Please help was working soooo goood .
TY
Dave S
VOYAGERUSA
 
Posts: 13
Joined: Tue Sep 11, 2012 7:54 pm

Re: WEBIDE AFTER SD CARD FAIL

by adafruit_support_bill on Wed Feb 13, 2013 8:02 am

What OS are you using? If you post full error messages and/or screen shots it might give us a clue to the problem.

adafruit_support_bill
 
Posts: 37521
Joined: Sat Feb 07, 2009 10:11 am

Re: WEBIDE AFTER SD CARD FAIL

by VOYAGERUSA on Wed Feb 13, 2013 1:11 pm

TY for reply
occidentalis v.2.

failed to obtain request token (status: 400 data: Invalid consumer.)
at OAuthStrategy.authenticate (/usr/share/adafruit/webide/node_modules/passport-bitbucket/node_modules/passport-oauth/lib/passport-oauth/strategies/oauth.js:183:36)
at exports.OAuth.getOAuthRequestToken (/usr/share/adafruit/webide/node_modules/passport-bitbucket/node_modules/passport-oauth/node_modules/oauth/lib/oauth.js:512:17)
at passBackControl (/usr/share/adafruit/webide/node_modules/passport-bitbucket/node_modules/passport-oauth/node_modules/oauth/lib/oauth.js:368:13)
at IncomingMessage.exports.OAuth._performSecureRequest.request.on.callbackCalled (/usr/share/adafruit/webide/node_modules/passport-bitbucket/node_modules/passport-oauth/node_modules/oauth/lib/oauth.js:380:9)
at IncomingMessage.EventEmitter.emit (events.js:126:20)
at IncomingMessage._emitEnd (http.js:366:10)
at HTTPParser.parserOnMessageComplete [as onMessageComplete] (http.js:149:23)
at CleartextStream.socketOnData [as ondata] (http.js:1367:20)
at CleartextStream.CryptoStream._push (tls.js:526:27)
at SecurePair.cycle (tls.js:880:20)
VOYAGERUSA
 
Posts: 13
Joined: Tue Sep 11, 2012 7:54 pm

Re: WEBIDE AFTER SD CARD FAIL

by adafruit_support_bill on Wed Feb 13, 2013 4:18 pm

occidentalis v.2.

But you said it was failing on "a computer other than the pi." What OS & browser are you running there?

adafruit_support_bill
 
Posts: 37521
Joined: Sat Feb 07, 2009 10:11 am

Re: WEBIDE AFTER SD CARD FAIL

by VOYAGERUSA on Wed Feb 13, 2013 4:41 pm

LINUX -KUBUNTU- CHROME
WIN 7 PRO -CHROME
WIN 7 ULTIMATE -CHROME
Tried on 3 different machines all with chrome on same network ,wifi or cat5.
all give log on to pi ok but when click to go to bitbucket it returns errors.
note :bitbucket told me ( Unfortunately, we cannot assist with the projects that are hosted here, nor third-party integrations. You should contact the maintainer of the web ide for assistance, or try their public groups].
all i can get.
Dave S
VOYAGERUSA
 
Posts: 13
Joined: Tue Sep 11, 2012 7:54 pm

Re: WEBIDE AFTER SD CARD FAIL

by adafruit_support_bill on Wed Feb 13, 2013 5:12 pm

I'll forward this to the WebIDE developers to see if they have any suggestions.

adafruit_support_bill
 
Posts: 37521
Joined: Sat Feb 07, 2009 10:11 am