Raspberry PI Camera Module Dead On Arrival
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

Raspberry PI Camera Module Dead On Arrival

by adnandzebic on Sun Oct 13, 2013 8:52 pm

Hello,

I ordered the Raspberry Pi Camera Module last month on Sept. 14 (http://www.adafruit.com/products/1367) and attempted to connect it to my Raspberry PI just a few days ago only to realize that it isn't working properly. When running the 'raspivid -t 5000' command the video never shows up although the red LED light is lit. Also the raspivid command fails to close naturally. I've tried using the camera module on a different Raspberry Pi and the same problem persists. I've also tried using different SD cards with different Raspbian images. Any advice would be greatly appreciated!!
adnandzebic
 
Posts: 2
Joined: Sun Oct 13, 2013 7:42 pm

Re: Raspberry PI Camera Module Dead On Arrival

by adafruit_support_mike on Mon Oct 14, 2013 12:35 am

According to the folks at the Raspberry Pi Foundation, almost all the camera problems they see are the result of cables not seating properly. Try re-seating the ribbon connector at both ends and check the troubleshooting information in the official documentation: http://www.raspberrypi.org/wp-content/u ... tation.pdf
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 10082
Joined: Thu Feb 11, 2010 2:51 pm

Re: Raspberry PI Camera Module Dead On Arrival

by adnandzebic on Tue Oct 15, 2013 2:06 pm

Thanks for the reply,

I've followed the pdf and all the steps outlined in the troubleshooting section but nothing seems to work. I can't think of what else to do to get it working. I've verified many times that the connector between the camera and the PI is properly aligned and in the right direction. Also the apt-get packagess are updated and upgraded. Could it be that the board is physically damaged?
adnandzebic
 
Posts: 2
Joined: Sun Oct 13, 2013 7:42 pm

Re: Raspberry PI Camera Module Dead On Arrival

by adafruit_support_mike on Tue Oct 15, 2013 3:22 pm

It's always possible to damage hardware, but the RasPi folks have a really good QA process to make sure hardware works before they let it out the door.

Try lifting and re-seating the little flex cable between the camera and the PCB. That one can work slightly loose in packing and shipping.

If that doesn't work, send a note to support@adafruit.com and we'll get you another one.
When you void a product warranty, you give up your right to sue the manufacturer if something goes wrong and accept full responsibility for whatever happens next. And then you truly own the product.
User avatar
adafruit_support_mike
 
Posts: 10082
Joined: Thu Feb 11, 2010 2:51 pm