MIDI Problem - Dropping notes from DAW when in MIDI Play Mode
Moderators: Altitude, adafruit_support_bill, adafruit, phono, mome rath

MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by maxobrien2 on Sat Oct 13, 2012 6:19 am

Hey guys,

Recently my x0xb0x has been playing up when I put it in MIDI play mode and control it with Ableton. It's basically dropping notes every now and then. I set up a really simple four note loop and then at random it'll just miss a note almost as if it was stuttering. I've tried this on two different MIDI interfaces and also test out other synths which seem to be working fine when controlled by my laptop so I'm pretty sure something is wrong with the x0xb0x.

Has anyone encountered a similar problem? Any advice you could offer would be amazing.

All the best,

Max
maxobrien2
 
Posts: 6
Joined: Thu Apr 05, 2012 9:21 am

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by antto on Sat Oct 13, 2012 8:24 am

i suspect your noteOFFs happen at the same time when other noteONs fire

i alsohave a theory that the original code in the firmware for the mdiplay mode is pretty broken - but i cannot test this myself
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1380
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by maxobrien2 on Sat Oct 13, 2012 1:21 pm

Thanks buddy, do you think there would be any way to fix this?
maxobrien2
 
Posts: 6
Joined: Thu Apr 05, 2012 9:21 am

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by antto on Sun Oct 14, 2012 3:55 pm

if it's the firmware fault - it can be modified
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1380
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by maxobrien2 on Sat Oct 20, 2012 4:56 am

That would be great, is there any way I download and install new firmware?

Thanks again for your help mate, it's much appreciated.

Max
maxobrien2
 
Posts: 6
Joined: Thu Apr 05, 2012 9:21 am

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by antto on Sat Oct 20, 2012 5:31 am

"new" is a tricky term
the source code for the stock firmware v1.05 is available at sourceforge
the source for the sokkos firmware is available with the .hex
i suspect this bug would persist in both, sadly

in case you don't have the sokkos firmware, you can get it from the forum (see x0xm0dz forum, there are 2 versions, i suggest get v2.0)
you can flash it with my c0nb0x app (see link in my signature)
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1380
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by maxobrien2 on Sat Oct 20, 2012 5:52 am

Thanks Antto. So is this a quite a common problem? I've upgraded to sokkos 2 but it's still happening sadly.

It sounds like the notes are dropping and sort of sliding up and down as if I'd drawn them overlapping.

Cheers,

Max
maxobrien2
 
Posts: 6
Joined: Thu Apr 05, 2012 9:21 am

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by antto on Sat Oct 20, 2012 11:07 am

well don't stick em so close (i mean the end of one note from the beginning of another)
overlapping them is interpreted as slide

sokkos is derived from the stock firmware and so any hidden bugs from that would have made their way to sokkos (and other firmwares)

it's possible that your DAW has something to do with it, if it sends the midi messages in a sloppy manner, this is a bit beyond my knowlage
but the easiest thing you can do is - try to leave empty space between notes, only overlap when you want slide
the 303/x0x internal sequencer always have such a gap, notes are not sustained till the next note (unless there's a slide, but then there's no retrigger)
:wink:
We are here too: irc.freenode.net >>> #x0xb0x
..:: c0nb0x v1.00 ::.. http://forums.adafruit.com/viewtopic.php?f=7&t=29282 (new control app - win/osx)
VCO Tuning: http://forums.adafruit.com/viewtopic.php?f=12&t=24759 (do it the EASY way)
User avatar
antto
 
Posts: 1380
Joined: Thu Apr 15, 2010 3:21 pm
Location: 127.0.0.1

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by Acrobatics on Sun Oct 21, 2012 3:08 pm

maxobrien2 wrote:Thanks Antto. So is this a quite a common problem? I've upgraded to sokkos 2 but it's still happening sadly.
It sounds like the notes are dropping and sort of sliding up and down as if I'd drawn them overlapping.
Cheers,
Max

Well known problem, Max, but lots of people often calls out overlapping which is absolutely irrelevant here: overlapping is intentional when you need the envelope continue over two different triggered notes and it's a REGULAR function which x0xb0x performs very well.
------------------------------------------------------------------------------------------
Here we are talking about MISSING notes and notes quite losing abruptly their pitch (when you hear a fast slide you have not programmed AT ALL).
Please don't always answer mentioning overlapping, sturdly assuming we are all noobies that can't see the difference between a legato and a MIDI bug. :|
User avatar
Acrobatics
 
Posts: 32
Joined: Mon Nov 22, 2010 8:25 am

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by Acrobatics on Sun Oct 21, 2012 3:13 pm

One trick I found to partially solve the problem is sending sixteens of notes on another channel, not the one in use. x0xb0x will someway get more "awaken" and will play almost all the notes. Try it and see if it works in your setup too.
User avatar
Acrobatics
 
Posts: 32
Joined: Mon Nov 22, 2010 8:25 am

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by maxobrien2 on Thu Nov 29, 2012 3:08 pm

Thanks for the advice guys, I've tried updating the firmware, using different DAWs, using an iPad to sequence the x0x but every time I'm getting the same problem. I've tried firing off 16th notes on another midi channel but that didn't help either.

If this is a known problem does that just mean loads of people are unable to control their x0xs using MIDI? Seems odd that there's no way to fix this. Might it be worth trying different firmware?

Thanks again for your help
maxobrien2
 
Posts: 6
Joined: Thu Apr 05, 2012 9:21 am

Re: MIDI Problem - Dropping notes from DAW when in MIDI Play Mode

by altitude on Sun Dec 02, 2012 8:15 am

Honestly, that sounds like there is something wrong with your box. What value do you have stuffed for the pull up resistor in the midi in circuit?

altitude
 
Posts: 978
Joined: Wed May 11, 2005 5:17 pm