MPL115A2 started providing incorrect pressure readings
Moderators: adafruit_support_bill, adafruit

MPL115A2 started providing incorrect pressure readings

by hilldnh on Sun Nov 18, 2012 10:00 pm

Starting a new post because search did not turn up any refs to this unit here.

I bought the MPL115A2 breakout board and connected it to my UNO. Downloaded the software and put the necessary files in the Arduino libraries area. Powered up and it was working great. Then worked on a separate sketch to log data. Reran the getpressure sketch and got readings that were way off: pressure (kPa) ~ -2850kPa and Temp (*C) =-12037 !

disconected, reconnected, reloaded, deleted and removed libraries, tried a second UNO. Still the same. Modified the .cpp file to turn on the printing and see:

Getting barometric pressure ...
A0 = 3591
B2 = FFFFC625
C12 = B06
a0 = 1714.13
b1 = -1.98
b2 = -0.90
10,000*c12 = 6.73

(theses seem about right)

raw press=272
raw temp=65033
Pressure (kPa): -2854.4987 kPa
Temp (*C): -12037.2 *C

raw temp seems way off

SDWN and RST pins on breakout board are floating.
Other I2C devices on the same breadboard are working fine.

Any ideas? It only ran well about 5min and has not worked since. could it be a bad unit?

Posts: 2
Joined: Sat Nov 17, 2012 11:17 pm

Re: MPL115A2 started providing incorrect pressure readings

by adafruit_support_bill on Mon Nov 19, 2012 7:44 am

What other I2C devices are on the bus? Make sure you have no address conflicts.

Posts: 37583
Joined: Sat Feb 07, 2009 10:11 am