Two triacs and two EL Panels turning off when only one should turn off
Moderators: adafruit_support_bill, adafruit

Two triacs and two EL Panels turning off when only one should turn off

by Dawn on Thu Jan 31, 2013 7:00 pm

I ordered two el panels and an inverter from adafruit. The inverter that I received with the el panels has two separate connectors, one for each el panel. My set up it, I have two optoisolators, one is connected to pin 7 and one is connected in pin 6 on my arduino uno. Each optoisolator is connected to a triac. I also have a pushbutton. I have it set up so that when the pushbutton is high one panel is high and the other is low. However, what is happening that that they are both turning off. I am not sure how that inverter is set up but it seems like since there are two seperate wire then, each should be independent of each other. However, since they are both turning off I assume that they are in series.

Does anyone have anyway to wire it so that only one turned off instead of both?

Thank you,

Dawn
Dawn
 
Posts: 9
Joined: Sun Dec 05, 2010 1:50 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by franklin97355 on Thu Jan 31, 2013 8:13 pm

You don't say which inverter but I suspect the two leads are tied together and are for convenience only. If you connect them so they would be open when off it should work. Show us how you have things connected and perhaps we can give you other options.
User avatar
franklin97355
 
Posts: 5495
Joined: Mon Apr 21, 2008 2:33 pm

Re: Two triacs and two EL Panels turning off when only one should turn off

by Dawn on Tue Feb 05, 2013 2:11 pm

I have attached a picture of the inverter that I am using to power my EL panels with since I could not find a picture of that I received on the website. I also drew a quick schematic and took a picture of the set up. However the difference of the actual set up is that in the schematic and picture, I have one more el panel. I just removed the other el panel for testing purposes.

The components that I am using to control the el panels are;
Triac MAC-97A4
NTE3044 Optoisolator Darlington Pair

I hope that it is clear and if there is any confusion or if it would be to clarify anything let me know.

Thanks for you help,

Dawn
Attachments
001.jpg
Schematic
001.jpg (115.64 KiB) Viewed 520 times
breadboard.jpg
picture of actual components
breadboard.jpg (364.49 KiB) Viewed 520 times
inverter.jpg
Inverter arrived with EL Panals from Adafruit
inverter.jpg (276.41 KiB) Viewed 520 times
Dawn
 
Posts: 9
Joined: Sun Dec 05, 2010 1:50 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Zener on Tue Feb 05, 2013 6:21 pm

If I understand correctly, when you push a remote transmitter,that will cause pins 6 and 7 on the processor to toggle, and that will turn triacs on and off, alternately. Is that right?

If so, are pins 6 and 7 transitioning as you expect?
Zener
 
Posts: 2641
Joined: Sat Feb 21, 2009 2:38 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Dawn on Tue Feb 05, 2013 6:31 pm

I have it set up is when I push the push button once the transmitter sends a -1. Which will turn the el panel on my right on and the el panel on my left off. When I press the push button twice, the transmitter sends -2. This is meant to turn the el panel on my left on and the right off.
I got this to work fine with just one panel, but when I try with both, they both are on instead of one off and one on.

I am thinking it has something to do with the inverter and a common ground but just can't seem to set up up right?
Dawn
 
Posts: 9
Joined: Sun Dec 05, 2010 1:50 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Zener on Tue Feb 05, 2013 6:46 pm

Zener wrote:are pins 6 and 7 transitioning as you expect?
Zener
 
Posts: 2641
Joined: Sat Feb 21, 2009 2:38 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Dawn on Tue Feb 05, 2013 7:34 pm

No.
Dawn
 
Posts: 9
Joined: Sun Dec 05, 2010 1:50 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Zener on Tue Feb 05, 2013 8:08 pm

You need to test each subsystem independently. First make sure the receiver is outputting anything. Then make sure the CPU is receiving that. Then make sure the pins 6 and 7 are acting correctly. Then test the triacs seperately and make sure they can control the EL. Once all that is working then you can put it all together.

Right now I am guessing you have a software issue in receiving and interpreting the radio message. That is assuming the radio receiver is working. You need to test that first.
Zener
 
Posts: 2641
Joined: Sat Feb 21, 2009 2:38 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Dawn on Wed Feb 06, 2013 12:00 am

I did try them independently. It works fine with one or the other but not with both of them. The receiver is getting the right signal for the right number of click, I am double checked the received input with serial.print. If I push the button once I get -1 twice I get -2.
Dawn
 
Posts: 9
Joined: Sun Dec 05, 2010 1:50 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Zener on Wed Feb 06, 2013 12:32 am

But if pin 6 and 7 don't act correctly then that is a software problem not an inverter problem. Yes?
Zener
 
Posts: 2641
Joined: Sat Feb 21, 2009 2:38 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Dawn on Wed Feb 06, 2013 12:48 am

But why does it all work fine when there is one panel and does not work fine when I add two?
Dawn
 
Posts: 9
Joined: Sun Dec 05, 2010 1:50 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Zener on Wed Feb 06, 2013 1:25 am

So, pins 6 and 7 act correctly when 1 inverter is attached?
Zener
 
Posts: 2641
Joined: Sat Feb 21, 2009 2:38 am

Re: Two triacs and two EL Panels turning off when only one should turn off

by Dawn on Sat Feb 09, 2013 5:33 pm

Phew, finally solved the issue. The wiring from the triac to the el panel was incorrect.

Thanks,

Dawn.
Dawn
 
Posts: 9
Joined: Sun Dec 05, 2010 1:50 am