Working GPS shield, but 3 years later, EM-406 can't get satellite fix

by djakopac on Wed Apr 18, 2012 5:00 pm

I have a version 1.0 GPS Shield and EM-406 GPS module. I bought these about three years ago, assembled them and it worked great. Unfortunately, the project I was working on was put on the shelf for a while. Last weekend I fired up an Arduino Duemilanove with a 328 chip, ran the Arduino 1.0 IDE, downloaded the latest sketch (https://github.com/adafruit/SD-Basic-GPS-logger) and ran it.

Logging to SD worked perfectly and the chip spit out NMEA strings. Unfortunately, they were all of the form:

Code: Select all
$GPRMC,235949.030,V,,,,,,,281006,,*21


(I.e., no location information and incorrect, or default, time and date info.)

I connected it up with a FTDI cable with the GPSPWR line connected to GND and am getting the same strings.

I ran it inside for several hours and outside for about 45 minutes--same results.

When I turn on the satellite output, I get:

Code: Select all
$GPGSV,3,1,12,20,00,000,,10,00,000,,31,00,000,,27,00,000,*7C
$GPGSV,3,2,12,19,00,000,,07,00,000,,04,00,000,,24,00,000,*76
$GPGSV,3,3,12,16,00,000,,28,00,000,,26,00,000,,29,00,000,*78


which indicates 12 satellites in view, but alt and azimuth from all are 0.

The red LED on the EM-406 module is solid red when powered and the NMEA strings appear to be output at 1Hz.

Seems like the satellite processing portion of the EM-406 is not working, but the other GPS module components are working (in that they produce correct NMEA strings, albeit without location information).

Just wondering if anyone else has seen similar behavior after a long period without use or has an suggestion--other than the obvious replacement of the EM-406.
User avatar
djakopac
 
Posts: 3
Joined: Wed Dec 21, 2011 10:41 am

Re: Working GPS shield, but 3 years later, EM-406 can't get satellite fix

by franklin97355 on Wed Apr 18, 2012 11:02 pm

$GPRMC,235949.030,V,,,,,,,281006,,*21

The V means VOID which means you do not have a lock on enough satellites. How long did you wait for a lock and are you outside?
User avatar
franklin97355
 
Posts: 2675
Joined: Mon Apr 21, 2008 1:33 pm

Re: Working GPS shield, but 3 years later, EM-406 can't get satellite fix

by djakopac on Wed Apr 18, 2012 11:23 pm

franklin97355 wrote:How long did you wait for a lock and are you outside?


I ran it outside for 45 minutes (I've made several attempts outside, the longest was 45 minutes, but several were about 10 minutes). I also tried inside near a window for several hours (at least two hours). Last time it worked, about three years ago, I got a lock within seconds outside, in the same spots. There are no tall buildings and none of these times outside was under a tree.
User avatar
djakopac
 
Posts: 3
Joined: Wed Dec 21, 2011 10:41 am

Re: Working GPS shield, but 3 years later, EM-406 can't get satellite fix

by adafruit on Thu Apr 19, 2012 6:19 pm

we've never heard of this happening, and we have a GPS unit much older than that (the first EM406A we got) that still works. we'll try to think of what could have happened
User avatar
adafruit
 
Posts: 11511
Joined: Thu Apr 06, 2006 3:21 pm
Location: nyc

Re: Working GPS shield, but 3 years later, EM-406 can't get satellite fix

by Fossum on Tue May 28, 2013 11:45 am

Funny, I have about the same issue with a somewhat new EM406. It just repeats the below text:
$GPRMC,151053.167,V,,,,,,,280513,,,N*43
$GPGGA,151054.167,,,,,0,00,,,M,0.0,M,,0000*52
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,151054.167,V,,,,,,,280513,,,N*44
$GPGGA,151055.167,,,,,0,00,,,M,0.0,M,,0000*53
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,151055.167,V,,,,,,,280513,,,N*45
$GPGGA,151056.167,,,,,0,00,,,M,0.0,M,,0000*50
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,151056.167,V,,,,,,,280513,,,N*46
$GPGGA,151057.167,,,,,0,00,,,M,0.0,M,,0000*51
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPRMC,151057.167,V,,,,,,,280513,,,N*47
$GPGGA,151058.167,,,,,0,00,,,M,0.0,M,,0000*5E
$GPGSA,A,1,,,,,,,,,,,,,,,*1E
$GPGSV,3,1,12,22,72,168,,14,37,026,,31,37,330,39,18,36,150,*73
$GPGSV,3,2,12,16,29,209,,25,20,035,,29,17,096,,06,09,201,*71
$GPGSV,3,3,12,21,06,153,,32,06,323,,03,-1,213,,01,-4,295,*74

It seems to have 12 satellites in view, but only one tracking... forever
Fossum
 
Posts: 1
Joined: Wed May 30, 2012 6:40 pm