Arduino ethernet board programming fails: avrdude resp=00
Moderators: adafruit_support_bill, adafruit

Arduino ethernet board programming fails: avrdude resp=00

by dg12 on Tue May 01, 2012 1:04 pm

Received arduino ethernet board.
Attempts to program it om Mac lion with Arduino 1.0.1rc2 via FTDI cable
report:
Code: Select all | TOGGLE FULL SIZE
"         Using Port                    : /dev/tty.usbserial-FTFO9AFU
        Using Programmer              : arduino
        Overriding Baud Rate          : 57600
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Send: 0 [30]   [20]
avrdude: Recv: . [00]
avrdude: stk500_getsync(): not in sync: resp=0x00"
+++++++++++++++++++++++

Monitor at 9600 reports "Reset done."
+++++++++++++++
It's talking to the Ethernet port, What is it doing?

I have attempted to reflash boot loader for optiLoader as per
http://arduino.cc/en/Main/ArduinoBoardEthernet reference to
http://scuola.arduino.cc/en/content/upg ... st-version
but that does not compile!
++++++++++++++++++++++++++++
Code: Select all | TOGGLE FULL SIZE
In file included from optiLoader.cpp:45:
optiLoader.h:6: error: 'byte' does not name a type
optiLoader.h:7: error: 'byte' does not name a type
optiLoader.h:8: error: 'byte' does not name a type
In file included from ... arduino/cores/arduino/Arduino.h:213,
                from optiLoader.cpp:67:
... arduino/variants/standard/pins_arduino.h:41: error: expected
unqualified-id before numeric constant
... arduino/variants/standard/pins_arduino.h:42: error: expected
unqualified-id before numeric constant
... arduino/variants/standard/pins_arduino.h:43: error: expected
unqualified-id before numeric constant


and several more.


1) How can I program this board?

2) What is it running to the ethernet port?

3) can it be programmed from the ethernet port?
dg12
 
Posts: 10
Joined: Sat Jan 29, 2011 10:13 pm

Re: Arduino ethernet board programming fails: avrdude resp=00

by adafruit_support_bill on Tue May 01, 2012 1:21 pm

Make sure you have the correct board type and COM port selected.
Hold the shift key down while pressing the upload button and post the diagnostic output.
User avatar
adafruit_support_bill
 
Posts: 30717
Joined: Sat Feb 07, 2009 10:11 am

Re: Arduino ethernet board programming fails: avrdude resp=00

by dg12 on Tue May 01, 2012 1:30 pm

Arrgh! So easy! I forgot to select etherboard. :oops:
Thank you.

Might you add a sticker to the board with a version number of the bootloader installed?
dg12
 
Posts: 10
Joined: Sat Jan 29, 2011 10:13 pm

Re: Arduino ethernet board programming fails: avrdude resp=00

by dg12 on Tue May 01, 2012 1:37 pm

Just to mention,
After successfully programing the ethernet board.
I uploaded again holding down shift while clicking on upload and got:

Code: Select all | TOGGLE FULL SIZE
avrdude: Yikes!  Invalid device signature.
         Double check connections and try again, or use -F to override
         this check.

Click upload without shift works.
again clicking upload with shift works, no additional output.
dg12
 
Posts: 10
Joined: Sat Jan 29, 2011 10:13 pm