Issue with 2.8 TFT (breakout Board version) IC1 extremely hot, no backlight.
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Issue with 2.8 TFT (breakout Board version) IC1 extremely hot, no backlight.

by damage on Wed Dec 12, 2012 10:06 pm

I have the 2.8 TFT (breakout version, Product ID# 335). The unit was working fine for several weeks however starting today The screen refuses to power up. I smelled the familiar smell of burning and by carefully feeling around found that IC1 was extremely hot. I am connected via 20pin ribbon, so I quickly unplugged the TFT and checked my connections. All pins seem to be wired up correctly, I am getting data on the data pins, voltage and ground where expected, no more then 5V on any pin. So I reconnected the TFT, Now nothing happens when powered up, IC1 doesn't get hot anymore (I presume it is fried). Of course if it has fried, I imagine other stuff is now toast as well.

Any ideas on what caused this and what I can do to fix it. I ordered an additional display today now that these are back in stock. I would still like to fix the one I have as ultimately I need 2 (I am building 2 copies of my current project).

Let me know, Thanks.

damage
 
Posts: 13
Joined: Sun Sep 26, 2010 1:22 pm
Location: Baltimore

Re: Issue with 2.8 TFT (breakout Board version) IC1 extremely hot, no backlight.

by damage on Thu Dec 13, 2012 12:10 am

Ok, so I have done some further testing. Definitely IC1 (the 3.3V Regulator) is blown. I connected 5V to it's input and got nothing out. I can only imagine that maybe at some point the internal thin ribbon cables underneath the panel shorted or there is/was some other intermittent short on my board. to test further I temporarily bypassed the 3v3 reg and supplied 3v3 directly to the output side of it and the LCD functions again. So I think I can maybe just replace the reg and salvage the thing. Still doesn't tell me what caused it in the first place.

Is this a suitable replacement for that vreg? Is that a SOT-5 package on the board? (i took my best guess)... http://www.mouser.com/ProductDetail/Texas-Instruments/LP2985-33DBVR/?qs=sGAEpiMZZMsGz1a6aV8DcCOj5hh%2fNjhX4p6toGEueJ8%3d

for reference, here is a direct link to the schematic... http://www.ladyada.net/images/tfttouchbreakout/tfttouchbreakoutsch.png

damage
 
Posts: 13
Joined: Sun Sep 26, 2010 1:22 pm
Location: Baltimore

Re: Issue with 2.8 TFT (breakout Board version) IC1 extremely hot, no backlight.

by adafruit_support_bill on Thu Dec 13, 2012 7:45 am

In the board files: https://github.com/adafruit/2.8-TFT-Breakout-PCB
It is listed as a "SOT23-5L"

adafruit_support_bill
 
Posts: 40185
Joined: Sat Feb 07, 2009 10:11 am

Re: Issue with 2.8 TFT (breakout Board version) IC1 extremely hot, no backlight.

by adafruit on Sat Dec 15, 2012 5:54 pm

LP2985-3.3 will do the job, perhaps you connected the polarity backwards?

adafruit
 
Posts: 11969
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Please be positive and constructive with your questions and comments.