Tutorial question
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

Tutorial question

by Hwestiii on Sun Dec 30, 2012 8:05 pm

Is the appropriate location for questions about the Adafruit tutorials for Raspberry Pi? I've completed the email and photo resistor tutorials, but am unable to get the sound file tutorial to work despite rechecking my wiring several times and verifyingt that the code is correct. pushing the buttons does not trigger the sound to play, so I inverted the logic and they all play unassisted, so I suspect the button circuit wiring is incorrect, but I have no clue why.
Hwestiii
 
Posts: 5
Joined: Sat Dec 29, 2012 12:25 pm

Re: Tutorial question

by Hwestiii on Sun Dec 30, 2012 8:36 pm

Actually, this seems like it might be an issue with the switches. I'm working with the Adafruit item 1014 Starter pack which comes with three momentary switches, but they do not look like the switches in the pictures in the tutorial. Are the switches in that kit not appropriate for that tutorial? I'm unable to get any on/off behavior. If the switch is plugged into the breadboard, I seem to get a circuit whether the button is pressed or not.
Hwestiii
 
Posts: 5
Joined: Sat Dec 29, 2012 12:25 pm

Re: Tutorial question

by adafruit_support_bill on Mon Dec 31, 2012 7:33 am

If the switch is plugged into the breadboard, I seem to get a circuit whether the button is pressed or not.

Can you post a photo showing how you have it connected?
User avatar
adafruit_support_bill
 
Posts: 31846
Joined: Sat Feb 07, 2009 10:11 am

Re: Tutorial question

by Hwestiii on Tue Jan 01, 2013 4:35 pm

I finally got this figured out. I did not understand what the correct orientation of the switches was. Thanks for the reply.
Hwestiii
 
Posts: 5
Joined: Sat Dec 29, 2012 12:25 pm

Re: Tutorial question

by holaparc on Thu Jan 03, 2013 2:45 am

You have to connect the pins of the switches that are diagonal to each other . I had to zoom into the picture in the tutorial to realize the mistake.
holaparc
 
Posts: 24
Joined: Fri Oct 19, 2012 11:21 am