Blue n White LCD direct display on Raspberry Pi not displaying white characters
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

Blue n White LCD direct display on Raspberry Pi not displaying white characters

by stulevine on Thu Jan 10, 2013 3:19 pm

I just received my Adafruit Blue&White 16x2 LCD+Keypad Kit for Raspberry Pi. And while I was all ready to solder this kit together to plug into my RPi, I realized I wanted the optional Stacking Header for Raspberry Pi which is currently out of stock.

So, in the interim I decided to use my cobbler and breadboard to light up the Blue&White LCD display alone using this tutorial "Drive a 16x2 LCD with the Raspberry Pi". When I was all finished wiring everything up, I used the Adafruit_CharLCD.py source code to test my work. At first it didn't look as if it was working. However, after increasing the contrast, I could see the text. But, it is not displaying as white text on the blue lit background. Instead, it is displaying as dark blue text and is very hard to read. Is this normal, or is there something in the code I need to change to get white characters? or perhaps the wiring? I ask since the tutorial is for a regular LCD and I'm using the one that came with the kit.

Here is a photo of the setup after wiring that show the dimly lit LCD

Can someone let me know if this is normal or if perhaps I need to adjust the code or wiring to get my white letters.

Thanks,

Stuart
stulevine
 
Posts: 9
Joined: Sun Dec 23, 2012 9:46 am

Re: Blue n White LCD direct display on Raspberry Pi not displaying white characters

by adafruit_support_bill on Thu Jan 10, 2013 3:34 pm

Looks like it could be a contrast adjustment problem, but I can't quite follow the wires connected to your pot. Double check that one side is connected to ground and the other to +5v. The orange wire should connect to the middle pin on the pot. VCC should also be 5v - not 3.3v.
User avatar
adafruit_support_bill
 
Posts: 30877
Joined: Sat Feb 07, 2009 10:11 am

Re: Blue n White LCD direct display on Raspberry Pi not displaying white characters

by stulevine on Thu Jan 10, 2013 4:52 pm

Oh, the pot is definitely wired up correctly. I've checked it several times and, in fact, if I take the pot out of the mix and wire up the the contrast wire directly to power, I get the same result. And, as far as I know I'm wired into the RPi 5v pin on the GPIO port of this new Raspberry Pi Model B. When I unplug and plug the back-light ground wire I see the characters display briefly in bright white, then the resort to the dark blue.
stulevine
 
Posts: 9
Joined: Sun Dec 23, 2012 9:46 am

Re: Blue n White LCD direct display on Raspberry Pi not displaying white characters

by adafruit_support_bill on Thu Jan 10, 2013 5:01 pm

OK then. Sounds like something wrong with the contrast circuit on that display. If you contact support@adafruit.com with a link to this thread they can arrange a replacement for you.
User avatar
adafruit_support_bill
 
Posts: 30877
Joined: Sat Feb 07, 2009 10:11 am



cron