Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

Screen 910 questions
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

Screen 910 questions

by doctorwho8 on Sun Jan 20, 2013 8:58 pm

Hello!
I bought earlier a 910 screen, that's http://www.adafruit.com/products/910 .

The power input guide lines say 4 volts to 15 volts, as here "Power with 4.5-15VDC only into onboard buck converter". And as it happens I got it to work briefly being powered by 5 volts coming from a power supply other then the one that came with my Raspberry PI starter Kit. I believe I saw the screen light up and show the video coming into it. I then decided to swap out the plug in power supply and try a battery pack, especially since I had hoped to build a portable system concerning my system.

I stopped when I thought I smelled smoke and felt the board. It felt warm right by the coils and the regulator.
And I know that's not normal.

Any suggestions?
doctorwho8
 
Posts: 32
Joined: Sat Aug 01, 2009 10:24 pm
Location: USA

Re: Screen 910 questions

by doctorwho8 on Sun Jan 20, 2013 11:15 pm

Hello!
While waiting for all of you to respond to my post update:[See below]
I decided to try again. This time trying a variety of 3 selected 1.5v cells in series, and then a battery pack that's normally sold for people to get their cells work in an almost any situation. Sadly I felt the same things happen that happened before. There was no video and no flicker from the backlights. I believe something went horribly wrong and I therefore believe I need an RMA to send the poor thing back for replacement. Screen is okay. It's the driver board that's bad.

doctorwho8 wrote:Hello!
I bought earlier a 910 screen, that's http://www.adafruit.com/products/910 .

The power input guide lines say 4 volts to 15 volts, as here "Power with 4.5-15VDC only into onboard buck converter". And as it happens I got it to work briefly being powered by 5 volts coming from a power supply other then the one that came with my Raspberry PI starter Kit. I believe I saw the screen light up and show the video coming into it. I then decided to swap out the plug in power supply and try a battery pack, especially since I had hoped to build a portable system concerning my system.

I stopped when I thought I smelled smoke and felt the board. It felt warm right by the coils and the regulator.
And I know that's not normal.

Any suggestions?
doctorwho8
 
Posts: 32
Joined: Sat Aug 01, 2009 10:24 pm
Location: USA

Re: Screen 910 questions

by adafruit_support_bill on Mon Jan 21, 2013 7:21 am

Contact support@adafruit.com with a link to this thread to arrange for a replacement.

adafruit_support_bill
 
Posts: 37506
Joined: Sat Feb 07, 2009 10:11 am