Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

WebIDE processes not killed?
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

WebIDE processes not killed?

by wbp on Thu Feb 07, 2013 1:17 pm

Been using the WebIDE to try out the RPi and learn a few things. Works really well, nice job Adafruit! I do notice though that every Run or Debug seems to create a new process on the RPi that never goes away. After a while "ps -ef" shows a slew of them, and eventually I have to reboot the box.

William
User avatar
wbp
 
Posts: 229
Joined: Mon Mar 07, 2011 1:18 pm

Re: WebIDE processes not killed?

by adafruit on Thu Feb 07, 2013 7:05 pm

the most helpful thing you can do is put in an issue on github - that way our developer will be sure to see it :)

adafruit
 
Posts: 11905
Joined: Thu Apr 06, 2006 4:21 pm
Location: nyc

Re: WebIDE processes not killed?

by wbp on Thu Feb 07, 2013 10:02 pm

Done. Took me a bit to find the repo, but it's posted now.
User avatar
wbp
 
Posts: 229
Joined: Mon Mar 07, 2011 1:18 pm

Re: WebIDE processes not killed?

by wbp on Tue Feb 12, 2013 4:52 pm

I posted this in the issue on github but thought I'd post it here as well.

Many of the examples floating around for the RPi have a "Press Ctrl-Z to end" message in them. I'm not sure where that came from, and I should know better, but since it was there, that's what I did. I guess I thought it might be something special for the WebIDE...

Of course it doesn't end the process, it only suspends it. No wonder I had all these processes sitting around! Doh...

It should, of course, say "Press Ctrl-C to end"...

William
User avatar
wbp
 
Posts: 229
Joined: Mon Mar 07, 2011 1:18 pm