Connecting Raspberry Pi with Wifi Module
Moderators: adafruit_support_bill, adafruit

Forum rules
Talk about Adafruit Raspberry Pi® accessories! Please do not ask for Linux support, this is for Adafruit products only! For Raspberry Pi help please visit: http://www.raspberrypi.org/phpBB3/

Re: Connecting Raspberry Pi with Wifi Module

by adafruit_support_rick on Sat Feb 23, 2013 3:10 pm

When you search for wifi access points on a computer, does this SSID show up in the list?

adafruit_support_rick
 
Posts: 13115
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Sat Feb 23, 2013 10:37 pm

Yes. The computer I'm using now is connected to it.
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm

Re: Connecting Raspberry Pi with Wifi Module

by adafruit_support_rick on Sun Feb 24, 2013 11:39 am

Well, that was pretty much my last idea. The symptoms you're seeing are the same as I saw when I tried to connect to a router with SSID broadcast disabled. I could only connect to that router from a computer by typing in the SSID on the computer - the router would not show up in any lists of available access points (didn't want the neighbors trying to get into it…).

It turns out that I had to enable broadcast to get the Pi to connect. Apparently, it's a LInux thing - even if linux knows the SSID, it still won't connect unless SSID broadcast is enabled.

Do you have some other access point you can try attaching to? Can you switch to WPA2 encryption? Can you try turning encryption off and see if you can attach that way?

adafruit_support_rick
 
Posts: 13115
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Sun Feb 24, 2013 1:23 pm

I might just try to wipe the pi and start from scratch. I can back up all the programs and other stuff I have on it...
Do you know of an easy way to do that?
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm

Re: Connecting Raspberry Pi with Wifi Module

by adafruit_support_rick on Sun Feb 24, 2013 3:28 pm

You can mount the SD card as a flash drive on your computer. Or you can get another SD, flash a fresh system on it, and see if you can get that to work first.

adafruit_support_rick
 
Posts: 13115
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Sun Feb 24, 2013 3:33 pm

I was also of thinking of trying to use the "network-config" package, but first I need to vnc working...
Do you think the network-config package would work? Or should I just give up and try with a new SD card?

Also, the only SD card I have laying around is an older 1GB card. Is that too small to install Raspbian?
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm

Re: Connecting Raspberry Pi with Wifi Module

by adafruit_support_rick on Sun Feb 24, 2013 4:29 pm

I must plead ignorance of network-config. :(

1GB is too small.

adafruit_support_rick
 
Posts: 13115
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Sun Feb 24, 2013 4:49 pm

I found an 8GB card, so I'll try to install fresh and see if it works.
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Mon Feb 25, 2013 7:40 pm

I just tried a fresh install, and I'm still not able to connect. I've got the same symptoms as before - everything seems alright, but I can't get the RPi to connect over WLAN.
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm

Re: Connecting Raspberry Pi with Wifi Module

by adafruit_support_rick on Tue Feb 26, 2013 12:33 am

I'm out of ideas. I think your wifi dongle works, but there's something strange about your wireless network. You'll probably have better luck with this over at the Raspberry Pi forums.

adafruit_support_rick
 
Posts: 13115
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Tue Feb 26, 2013 10:21 pm

OK. So, I FINALLY got it working when I found an older copy of Wheezy (from september) that worked with the RTL8188CUS setup script (instructions). Now, I'm able to ssh into my pi and ping any of the computers on my local network on it. The problem is that it seems like I'm unable to get an internet connection. When I try
Code: Select all | TOGGLE FULL SIZE
ping google.com
I get this result:
Code: Select all | TOGGLE FULL SIZE
connect: Network is unreachable
. Do you know what might be causing this or how I could fix it?
@driverblock - Thanks again for all the help you've given (here and on the other thread)!


EDIT: I just rebooted my pi and now it works totally fine, without any problems at all. So, if anyone else has a similar problem, just run
Code: Select all | TOGGLE FULL SIZE
sudo shutdown -r now
, and it may work itself out.
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm

Re: Connecting Raspberry Pi with Wifi Module

by adafruit_support_rick on Wed Feb 27, 2013 12:28 pm

Nice work! Congrats!

adafruit_support_rick
 
Posts: 13115
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Wed Mar 06, 2013 11:57 pm

So I'm back... with yet another problem.
My wifi has been working without problems since I last posted, but just tonight I've started having problems with it. It seems that every 2 or 3 minutes the wifi just drops out, and I can't ssh into the pi anymore. I can fix it by unplugging the usb hub (with wifi adapter), and plugging that in, but I need my sensors running even while I'm out of the house. I've checked my power supplies (the USB hub is 5v 1a), and I don't think that's the problem, but I just can't figure out why the wifi drops out like this.
Do you know what might be causing this?
Thanks!
Peter
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm

Re: Connecting Raspberry Pi with Wifi Module

by adafruit_support_rick on Thu Mar 07, 2013 12:02 pm

You might want to check your hub against the naughty or nice lists.

adafruit_support_rick
 
Posts: 13115
Joined: Tue Mar 15, 2011 11:42 am
Location: Buffalo, NY

Re: Connecting Raspberry Pi with Wifi Module

by pandring on Thu Mar 07, 2013 7:24 pm

My hub ("GearHead 4 Port Hub with Energy Saving Power Switch (5 V, 1 A)") seems to be on the nice list, but it's also crossed out in the "non-working" section.
Oddly enough, This morning I tried to plug the wifi straight into the Pi, and it's been working for about 10 hours now. Should I potentially look into buying a new USB hub? It seems like this one may be causing the problem.
pandring
 
Posts: 25
Joined: Sun Dec 02, 2012 5:15 pm