Memorial day is 05/25/2015 – Orders will ship out on May 26th. There will not be any deliveries or shipping on Monday. Any order placed after 11am ET on Friday May 22nd will not start to ship out until Tuesday May 26th.

Troubleshoot Data Logger Shield SD Card Not Initialised
Moderators: adafruit_support_bill, adafruit

Troubleshoot Data Logger Shield SD Card Not Initialised

by padraigmac on Sat Mar 23, 2013 6:16 pm

HI,

I purchased a self-assembly Data Logger Shield Kit a few months ago and have only gotten around to assembling it this week. The assembly went well, and the first trial for RTC was successful also. When I try CardInfo, the serial monitor is returning "SD Card Not Initialised". It does this whether there is an SD Card in there or not. I have tried two 4GB SD Cards, both source from Adafruit, and formatted both with SD Formatter V3.1, with no success.

I have continuity on the SD Card Holder pins I can test with multimeter, and the GND pins all match as they are supposed to.

I believe I assembled the board correctly - see video here http://www.youtube.com/watch?v=OlUvreFuPns

Has anyone got any ideas on where the problem can relate to?
padraigmac
 
Posts: 2
Joined: Sat Mar 23, 2013 6:04 pm

Re: Troubleshoot Data Logger Shield SD Card Not Initialised

by adafruit_support_bill on Sun Mar 24, 2013 7:08 am

It is a little hard to see in the video, but some of the SD card holder solder joints look suspect. Testing with a multimeter is not conclusive - since poking an intermittent connection with a probe typically makes it conductive. Re-work any that are not smooth and shiny or have not flowed well onto both the pin and the pad.

adafruit_support_bill
 
Posts: 37568
Joined: Sat Feb 07, 2009 10:11 am

Re: Troubleshoot Data Logger Shield SD Card Not Initialised

by padraigmac on Sun Mar 24, 2013 1:23 pm

Truly awesome support - you were correct in identifying the solder problem - I did not have enough on pin 7 - the connection looked good but no solder appeared to have flowed around connection - reflowed and the board is working well now.

Many thanks for your help.

Regards, Padraig
padraigmac
 
Posts: 2
Joined: Sat Mar 23, 2013 6:04 pm



cron