FTDI Friend install problem on Windows 7 64-bit
Moderators: adafruit_support_bill, adafruit

FTDI Friend install problem on Windows 7 64-bit

by mstebbins on Fri Dec 31, 2010 1:23 pm

Hello, I just received my first Boarduino and FTDI friend from ladyada. As the subject line says, I am using a 64-bit Windows 7 machine. I follow the instructions for installing the FTDI Friend (http://www.ladyada.net/learn/breakoutpl ... riend.html) and everything goes as planned until after I install the driver for the USB serial port (the 2nd driver install). Instead of it completing successfully, I get a window saying that "Windows encountered a problem installing the driver software for your device: "Window found driver software for your device but encountered an error while attempting to install it. Windows cannot load the device driver for this hardware. The driver may be corrupted or missing. (Code 39)". Device Manager shows the device under Ports (COM & LPT) as "USB Serial Port (COM8)" with a yellow triangle and exclamation point.

I have tried both 2.08.02 and 2.08.08 from the site linked to in the FTDI Friend tutorial (http://www.ftdichip.com/Drivers/VCP.htm). I've tried uninstalled and reinstalling each several times with no luck. Finally, I tried installing on an old 32-bit XP machine at work, and that installation went well and allowed me to upload Blink to the Boarduino, so the cable, FTDI Friend, and Boarduino all seem to be working. It seems to be a Windows 7 64-bit issue.

Any suggestions on what to try next? Thanks for your help.
mstebbins
 
Posts: 4
Joined: Fri Dec 31, 2010 1:09 pm

Re: FTDI Friend install problem on Windows 7 64-bit

by adafruit_support_bill on Fri Dec 31, 2010 2:01 pm

Here is the explanation of error code 39 from Microsoft Support (you'll need t scroll down a bit). http://support.microsoft.com/kb/310123
FTDI likely left something out of the 64 bit version of the installer. You might try FTDI tech support.
User avatar
adafruit_support_bill
 
Posts: 29635
Joined: Sat Feb 07, 2009 9:11 am

Re: FTDI Friend install problem on Windows 7 64-bit

by mstebbins on Fri Dec 31, 2010 2:29 pm

Thanks for the response. I've sent a note to FTDI and will report back with anything they give me for others' benefit.

In the meantime, have others had this problem when using the FTDI Friend with Windows 7 64-bit, and if so, how did you solve it?
Mike
mstebbins
 
Posts: 4
Joined: Fri Dec 31, 2010 1:09 pm

Re: FTDI Friend install problem on Windows 7 64-bit

by mitpatterson on Sat Jan 01, 2011 8:07 am

I run windows 7 64-Bit and i had no troubles at all with it..... so must just vary on what other software and hardware you have
mitpatterson
 
Posts: 196
Joined: Mon Aug 02, 2010 10:45 pm

Re: FTDI Friend install problem on Windows 7 64-bit

by adafruit_support_bill on Sat Jan 01, 2011 10:09 am

I took a look at my Win-7 64-bit system. I have the 2.8.2.0 version of the FTDI driver installed. As I recall, it installed without issue.
I wonder if there might be a conflict with some other driver in the USB stack. Or possibly some dependency on an update to some other driver or system file. Is your machine up-to-date with all the Windows Update patches?
User avatar
adafruit_support_bill
 
Posts: 29635
Joined: Sat Feb 07, 2009 9:11 am

Re: FTDI Friend install problem on Windows 7 64-bit

by mitpatterson on Sat Jan 01, 2011 11:44 am

Actually just for fun(on a fresh windows install) i just plugged it in and let windows use windows update, and it installed just fine. I have yet to ever actually use the FTDI friend for anything at all, as i don't think i have anything specific to use it for. Here is a screen shot showing the driver it auto installed:
Capture.JPG
FTDI Friend Driver installed
Capture.JPG (43.92 KiB) Viewed 6255 times
mitpatterson
 
Posts: 196
Joined: Mon Aug 02, 2010 10:45 pm

Re: FTDI Friend install problem on Windows 7 64-bit

by mstebbins on Sun Jan 02, 2011 2:39 am

Yes, I have all windows updates installed. 2.8.2 is one of the two drivers I tried to use. It must be a conflict with something else.
I will wait for a reply from FTDI before going to the trouble of uninstalling other USB drivers to see if that solves the issue, as this machine is my only machine, and I can't afford to mess something else up just to make the FTDI Friend work. Unfortunate, as I've been quite excited to get into Arduino for some time and now I'm already stuck! I'll post what I learn. Thanks for the help.
mstebbins
 
Posts: 4
Joined: Fri Dec 31, 2010 1:09 pm

Re: FTDI Friend install problem on Windows 7 64-bit

by mstebbins on Wed Jan 12, 2011 4:16 pm

I've been emailing back and forth over the past week or so with an engineer at Future Technology Devices International, LTD.

Things I tried:
  • Removing all drivers for previous FTDI devices: ((http://ftdichip.com/Support/Utilities/C ... r_v1.4.zip)
  • Disabling network and wireless devices before re-installing drivers
  • Ensuring that the “load VCP“ option is enabled when under the Properties section of the USB serial converter in Device Manager.
  • Updating my USB host controller drivers

I tried many variations of the above, even going so far as showing all phantom devices in Device Manager and deleting the drivers for those that were unneeded. I finally installed the FTDI Friend on another Windows 7 64-bit machine, and it worked without issue. I'm writing this off to a bad Windows install, and when I have a free moment (or many moments!), I'll try a repair or re-install.

Thanks to everyone for their assistance, and to FTDI for quick responses to my trouble-shooting emails.
mstebbins
 
Posts: 4
Joined: Fri Dec 31, 2010 1:09 pm