Cannot communicate with Arduino Mega 2560
Moderators: adafruit_support_bill, adafruit

Cannot communicate with Arduino Mega 2560

by consi on Tue Jun 14, 2011 9:47 am

I have recently purchased an Arduino Mega 2560 and it simply does not communicate with my PC. When I plug the USB cable into the board the power light goes on but there is no interaction with the PC (e.g. no "installing device driver" message) and I cannot download programs to the board. I have many Arduino boards (older MEGAs) and they all can communicate with my development system - -which leads me to believe that my computer, cable, communications port and development software are all working. My conclusion is that the Mega 2560 has a problem, potentially in the ATMEGA8U2 chip that is used as the serial to USB converter. I would appreciate any suggestions from people who may have had similar problems.

thanks!

tom
consi
 
Posts: 3
Joined: Tue Jun 14, 2011 9:41 am

Re: Cannot communicate with Arduino Mega 2560

by adafruit_support_bill on Tue Jun 14, 2011 11:10 am

The MEGA 2650 uses a different driver than the older MEGA's. Does the board show up anywhere in the device manager?
User avatar
adafruit_support_bill
 
Posts: 29613
Joined: Sat Feb 07, 2009 9:11 am

Re: Cannot communicate with Arduino Mega 2560

by consi on Tue Jun 14, 2011 11:35 am

No, the board does not show-up in the Device Manager.
consi
 
Posts: 3
Joined: Tue Jun 14, 2011 9:41 am

Re: Cannot communicate with Arduino Mega 2560

by adafruit_support_bill on Tue Jun 14, 2011 3:03 pm

Are there any other signs of life other than the green power led?
Try it with at least one other USB cable.
User avatar
adafruit_support_bill
 
Posts: 29613
Joined: Sat Feb 07, 2009 9:11 am

Re: Cannot communicate with Arduino Mega 2560

by consi on Tue Jun 14, 2011 3:31 pm

The LED attached to pin 13 does blink for a short time on start-up. The Tx and Rx lights are never active, even when trying to upload a sketch. I have tried multiple USB cables to no avail.
consi
 
Posts: 3
Joined: Tue Jun 14, 2011 9:41 am

Re: Cannot communicate with Arduino Mega 2560

by adafruit_support_bill on Tue Jun 14, 2011 3:51 pm

Contact support@adafruit.com about a replacement. Reference this thread in your message.
User avatar
adafruit_support_bill
 
Posts: 29613
Joined: Sat Feb 07, 2009 9:11 am

Re: Cannot communicate with Arduino Mega 2560

by idem on Thu Aug 11, 2011 7:01 am

Hey,
I've have the same problem last night with an arduino Mega2560 :(
Working on IDE, and after a power OFF / power ON I just have power LED on, and TX/RX off.
Can't connect with my usual laptop, trying with 2 others computers and alway same result :
no new component found on windows...and no way to connect with a serial that is not detected.

Any issue?

Regards,
Mehdi
idem
 
Posts: 32
Joined: Thu Aug 11, 2011 6:39 am
Location: FRANCE

Re: Cannot communicate with Arduino Mega 2560

by adafruit_support_bill on Thu Aug 11, 2011 8:41 am

Have you successfully communicated with this board before?
How is the board powered? (USB or via DC power jack)
User avatar
adafruit_support_bill
 
Posts: 29613
Joined: Sat Feb 07, 2009 9:11 am

Re: Cannot communicate with Arduino Mega 2560

by idem on Thu Aug 11, 2011 8:56 am

Have you successfully communicated with this board before?
How is the board powered? (USB or via DC power jack)


I successfully communicated with this board during 1 week, and other boards have no pb.
I'm using mostly USB, but tried with DC power too.
I tried without my ethernet shield, without protoboard, really alone, and no RX/TX led, no detection in device manager.

In hurry, I bought an other one in adafruit shop :)
But I'm very disapointed for the other one.
idem
 
Posts: 32
Joined: Thu Aug 11, 2011 6:39 am
Location: FRANCE

Re: Cannot communicate with Arduino Mega 2560

by adafruit_support_bill on Thu Aug 11, 2011 9:24 am

One possibility is that the device configuration is corrupted. If you can find the device in the device-manager, delete it and see if it will recognize it the next time you plug it in.

Or the board could be dead. It is not common, but these devices can be damaged by ESD. As an unprotected circuit board, they require more care than an enclosed electronic device.
User avatar
adafruit_support_bill
 
Posts: 29613
Joined: Sat Feb 07, 2009 9:11 am

Re: Cannot communicate with Arduino Mega 2560

by idem on Thu Aug 11, 2011 12:42 pm

really?
I'm working with expensive card and never have ESD problem.
I really take care of my cards, and don't know how I can kill it.
Is there a way to fix it?
idem
 
Posts: 32
Joined: Thu Aug 11, 2011 6:39 am
Location: FRANCE

Re: Cannot communicate with Arduino Mega 2560

by adafruit_support_bill on Thu Aug 11, 2011 4:03 pm

If it is just the USB/Serial converter, you can still use the board with an FTDI cable.
Some have successfully replaced the chip. But SMT soldering is not so easy without the right equipment.
User avatar
adafruit_support_bill
 
Posts: 29613
Joined: Sat Feb 07, 2009 9:11 am

Re: Cannot communicate with Arduino Mega 2560

by mostlyiguessso on Fri Apr 20, 2012 7:55 pm

I have also had the same problem. I found something obscure about fixing the converter chip but I didn't understand it very well...
Any help would be appreciated!
mostlyiguessso
 
Posts: 2
Joined: Fri Apr 20, 2012 7:52 pm

Re: Cannot communicate with Arduino Mega 2560

by mostlyiguessso on Fri Apr 20, 2012 8:01 pm

Here is the post about reflashing the 8u2 chip.

http://www.arduino.cc/cgi-bin/yabb2/YaB ... 8093/34#34

Can't make much sense of it though.
mostlyiguessso
 
Posts: 2
Joined: Fri Apr 20, 2012 7:52 pm

Re: Cannot communicate with Arduino Mega 2560

by adafruit_support_bill on Sat Apr 21, 2012 4:53 am

There is a clearer explanation of the procedure here:
http://arduino.cc/en/Hacking/DFUProgramming8U2
User avatar
adafruit_support_bill
 
Posts: 29613
Joined: Sat Feb 07, 2009 9:11 am