The new Raspberry Pi B Model B+ is here - Pick one up in the store and check our detailed guide!

Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Wed Mar 28, 2012 8:41 am

Hi there,
I've finish building two x0xb0x. Everything works perfectly, except all LED on the right hand side all lights up and doesn't go off. Although they doesn;t affect any control on the SEQ. Does anyone has any idea why they lights up in every mode? The x0xb0x is fully functional on all mode such as keyboard mode and pattern edit mode. Every Key has response when I press them. It;'s only the LED on the right hand side all lights up. They are 14 15 16 17 22 23 24 225 26 27 34 35 36 37 38 39 40
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by guest on Wed Mar 28, 2012 2:48 pm

it is most likely that ic7 is bad

turn power off to the x0x
measure the resistnance between pin9 on ic7 and pin14 on ic6
it should be 0ohms
then measure the resistance between pin14 and pin16 on ic6
it should be at least 10kohms

if those readings look good
replace ic7
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 4:35 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Wed Mar 28, 2012 8:48 pm

thanks for the reply.

measure the resistnance between pin9 on ic7 and pin14 on ic6
I accidently turn the meter to 200M to test the resistance on the IC and got a reading of 00.9 , I hope I didn't fry the IC. I got reading of 0ohms when I switch it back to 2M or 200k mode.

then measure the resistance between pin14 and pin16 on ic6
I got reading of 1.1M . Is it too big?

Both of the unit have the same problem. It's too co-incident both unit has problem on IC7 as well. Does IC7 control the LED lights?
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by guest on Wed Mar 28, 2012 9:40 pm

if you have 2 x0xen with identical problems
then the problem is most likely in the pcb

where did you get your x0x kit from

ic4 through ic8 control the leds
they pass data in a line
which is why you have the last ones all going on

check to see if any of the ics are getting hot
look for shorts all around ic4 and ic6

if you cant find anything
replace ic4 and see if it fixes it
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 4:35 am

Re: Everything works perfectly but half of the LED lights up!!!!

by guest on Wed Mar 28, 2012 9:41 pm

and double check that ic4 is the right part
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 4:35 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Thu Mar 29, 2012 6:33 am

I bought them from Willzyx music. I have also checked the following :
pin 12 of IC4,5,6,7,8 is all shorted
pin 11 of IC4,5,6,7,8 is all shorted
IC4 pin 9 is shorted to IC5 pin 14
IC5 pin 9 is shorted to IC7 pin 14
IC7 pin 9 is shorted to IC6 pin 14
IC6 pin 9 is shorted to IC8 pin 14
IC4 - 8 pin 13 is sll gnd
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Thu Mar 29, 2012 6:33 am

the resistance between pin14 and pin16 on ic6
I got reading of 1.1M . Is it too big?
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Thu Mar 29, 2012 6:40 am

there is only a few LED working correctly, they are LED 2 3 4 5 6 7 8 9 10 11 12 13 19 20 21 30 33
I bought the PCB from Willzyx, but I source 74HC595 myself. Do u think it is the IC problem?
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Thu Mar 29, 2012 7:21 am

pin 12 of IC4,5,6,7,8 is all shorted
pin 11 of IC4,5,6,7,8 is all shorted
IC4 pin 9 is shorted to IC5 pin 14
IC5 pin 9 is shorted to IC7 pin 14
IC7 pin 9 is shorted to IC6 pin 14
IC6 pin 9 is shorted to IC8 pin 14
IC4 - 8 pin 13 is sll gnd
then I so some testing when the x0xb0x is switch on :
IC8 pin 14, it is DC 4.95V, and I press all keys and reading remain unchange
IC7 pin 14 is 0.01V and press all keys and it has no change
IC6 pin 14 is 4.95V and I press all keys it has no change
IC5 pin 14 0.01V and I press all keys, nothing is change
IC4 pin 14 is 4.92V and I press all keys and nothing is change
I thought pin 14 they suppose to have same voltage?
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Thu Mar 29, 2012 7:32 am

In AC mode, IC5 to IC8 pin 14 is all 0.001V AC, pressing all keys has no change on the voltage. Except IC4 pin 14 is AC0.29V, but pressing the key doesn;t make the voltage change too
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Thu Mar 29, 2012 9:34 am

I have change IC 6 7 8 to some new IC from other supplier and most of the LED is working now. there is still four LED not working which is LED18 28 31 32. I will change the remaining two IC and see how it goes,.
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by 975262801 on Thu Mar 29, 2012 7:10 pm

Hi, problem solved, thanks. It is the 74HC595. No idea why they does not work properly. They are brand new ST micro.
975262801
 
Posts: 30
Joined: Wed Feb 01, 2012 1:06 am

Re: Everything works perfectly but half of the LED lights up!!!!

by guest on Thu Mar 29, 2012 9:08 pm

good to hear
sometimes there is a bad batch
it all depends upon the supplier
guest
 
Posts: 3155
Joined: Fri Feb 17, 2006 4:35 am