0

Gemma m0 missing bootloader file
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

Gemma m0 missing bootloader file

by coalkine on Sat Sep 16, 2017 9:21 pm

Been trying to get the gemma m0 working with the arduino ide without any luck. I keep getting the following message win trying to upload code to the gemma.

Bootloader file specified but missing: C:\Users\HP-450\AppData\Local\Arduino15\packages\adafruit\hardware\samd\1.0.19\bootloaders\gemma\samd21_sam_ba.bin
Sketch uses 15128 bytes (5%) of program storage space. Maximum is 262144 bytes.
No device found on COM21
An error occurred while uploading the sketch

I have updated all board support files, using arduino ide 1.8.1, running windows 7 (installed latest adafruit drivers), and the computer dose recognize the gemma (did try another gemma with same results), and the code works fine on my nano just needed a something smaller to fit my project.

ps - using arduino ide and don't wont to have to install another program just to use the gemma.

thanks for any help you can provide.

coalkine
 
Posts: 2
Joined: Sun Nov 29, 2015 12:16 am

Re: Gemma m0 missing bootloader file

by fretinator on Wed Sep 27, 2017 1:05 pm

I am in the same boat with my new Metro M0 Express. I have the SAMD for Arduino and Adafruit both installed and the board shows up, is on the correct COM port, but I get the same error about the missing samd21_sam_ba.bin. I wonder if installing an older version of the Adafruit SAMD boards would work. Perhaps this board is not yet supported for Arduino.

p.s. - I'm on Windows 10.

fretinator
 
Posts: 2
Joined: Wed Sep 27, 2017 1:02 pm

Re: Gemma m0 missing bootloader file

by fretinator on Wed Sep 27, 2017 1:55 pm

Here is what I did for now to get it to work. The system was looking for the bootloader at:

C:\Users\freti\AppData\Local\Arduino15\packages\adafruit\hardware\samd\1.0.18\bootloaders\metro

There was no metro subfolder under bootloaders. However, I found the file under a directory named "zero", and I sometimes see the M0 described as a Zero board, so I copied the "zero" folder and named the new folder "metro" and now the compile and upload works. Fun times!

fretinator
 
Posts: 2
Joined: Wed Sep 27, 2017 1:02 pm

Re: Gemma m0 missing bootloader file

by coalkine on Thu Sep 28, 2017 9:18 pm

Thanks fretinator, cleared up the missing file problem but still saying that there is no device on the com port.

coalkine
 
Posts: 2
Joined: Sun Nov 29, 2015 12:16 am

Re: Gemma m0 missing bootloader file

by lighting101 on Sun Oct 01, 2017 7:45 pm

i am just having trouble uploading to gemma i have a macbook not the pro just a Macbook and i have been having issues uploading can someone please help.

Thanks Again
Amber

lighting101
 
Posts: 14
Joined: Mon Nov 10, 2014 8:17 pm

Please be positive and constructive with your questions and comments.