0

MiniPOV4 Not Working, Possible Atmega328 Issue
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

MiniPOV4 Not Working, Possible Atmega328 Issue

by Mykal451 on Mon Dec 18, 2017 9:59 pm

MiniPOV4 - Order No: 1625915-5351701303 (Purchased Dec 12 2017)

Assembly went well, when powered on there is no light from any LED. I think my Atmega328 chip may not have been programmed or is defective. I do have a spare Atmega328P-PU available to program.

With O-Scope I verified 12MHz crystal is working, also verified transistors / diodes are good.

I programed and installed an Atmega328 from an Arduino UNO and can get LEDs to light up per my code.

I did see the MiniPOV4 file package on GitHub, with Bootloader and Firmware but not sure how to install code.

I do own a Pocket AVR Programmer but not sure what the next step is (Using Mac OS), would I just use AVRDude and load the bootloader hex file or can I use Arduino IDE.

Thanks for your assistance !!
michael
Attachments
MiniPOV4-top.JPG
MiniPOV4 Top Image
MiniPOV4-top.JPG (488.68 KiB) Viewed 570 times
MiniPOV4_bottom.JPG
MiniPOV4 Bottom Image
MiniPOV4_bottom.JPG (480.28 KiB) Viewed 570 times

Mykal451
 
Posts: 2
Joined: Sun Dec 17, 2017 2:24 am

Re: MiniPOV4 Not Working, Possible Atmega328 Issue

by Mykal451 on Fri Dec 22, 2017 11:28 am

Working but still one issue to figure out . . . the main issue was my Atmega328 wasn't programed . . . bummed this happened but learned a lot more in the process, silver lining I guess ??

Had no clue how to proceed but tried this . . . I used my Pocket AVR + Avrdude (MacOS) to load the minipov4all.hex image, still confused about how this hex file can be the bootloader and the program code (MiniPOV4Core.ino).

But . . . in the process I ran in to two other hiccups . . .

1) The latest version of "Processing" (version 3) won't run the MiniPov4_ImageConverter.pde program, had to back rev to 2.x, this should be added to the MiiPOV4 instructions.
2) The MiniPOV4 won't display any image except the minipov4test.png image, seems larger images will load via USB + loader App but won't display anything, will create a few images of my own and see where the breaking point is. Any thoughts here Adafruit Support ?

Regards,
michael

Mykal451
 
Posts: 2
Joined: Sun Dec 17, 2017 2:24 am

Re: MiniPOV4 Not Working, Possible Atmega328 Issue

by marzdarz on Sat Jan 12, 2019 1:38 am

Did you get it working? How did you program it?

marzdarz
 
Posts: 3
Joined: Sat Jan 12, 2019 1:16 am

Please be positive and constructive with your questions and comments.