0

difficulty programming MiniPOV4
Moderators: adafruit_support_bill, adafruit

Please be positive and constructive with your questions and comments.

difficulty programming MiniPOV4

by dc49 on Mon May 31, 2021 3:04 pm

Hello,
I've assembled my MiniPOV4 and it works with the preloaded image. When I attach it to my Mac, I don't see any device mount. I have a newer Mac with only USBC cables so I use an adapter. I'm not sure if it is mounted or not.

When I launch the Processing image converter program and try to download the test image, I get the following error:
"java.io.IOException: Cannot run program "/Users/dc/Documents/garage/MiniPov4_ImageConverter/avrdude": error=86, Bad CPU type in executable"

Am I missing something?

Thanks
DC

dc49
 
Posts: 1
Joined: Mon May 31, 2021 2:50 pm

Re: difficulty programming MiniPOV4

by mikeysklar on Mon May 31, 2021 8:27 pm

The MiniPOV4 will not show a mounted device as in a drive popping up with a filesystem. There should be able to see new devices appear in /dev on your MacOS box with things are working. The system profiler on MacOS under USB devices can also help show what is connected.

You will probably need to try a USB2 hub in the mix as USB3 with converter dongles has been an issue.

Are you running an M1 MacBook? That might explain the avrdude compilation issue. You were attempting to run the MacOS release of processing correct?

mikeysklar
 
Posts: 5465
Joined: Mon Aug 01, 2016 8:10 pm

Please be positive and constructive with your questions and comments.